Enable Serial output in install images

Please enable serial output for the installation medias.
Just add “console=ttyS0,115200” as kernel parameter.


there is a boot option “with serial console”. If you select that, the system will come up with the serial console enabled.


You can’t select the option when GRUB doesn’t start in serial mode :wink:
I am talking about devices without video-output - like APU.

The install media does not use grub. It use syslinux and the serial input is enabled on all install images but you have to choose the correct menu entry for installation with serial console.

Also on the flash media at first boot the serial console is enabled but you have to choose the matching option to leave it enabled. (Enabled serial console does not support graphic modes so we disable it if not needed)

Special for apu the serial console will always enabled if you are wait long enough also if you have not choosed the correct grub option.

I am talking about the flash media. I cannot confirm that i get any output on the serial port of APU devices since the last few releases. Adding the described kernel parameter always fixed it for me and let me config IPFire.

I have last tested this with core135 on apu1 and apu2. (The code was not changed in core 136,137 and 138)
Daniel has also use this on apu4.

Which bios is on your apu?

I have testead again with core138 x86_64

if i now not choose serial console it stand for 2 Minutes with this:

and then it reboot with enabled serial console:

I’m pretty sure, i never saw the the serial-option when i tried the last times. But maybe i am wrong. Will try the next time the way you described.

This menuentry exist since IPFire 2.21 core122 but only at first boot. The autoenable for apu if the menu was missed at first boot was added later.

with IPFire 2.21 core128

Ah, i see. So if i miss to enable it during the first boot, i have to set it manually or reflash the disk.
Would it be an option to enabe it per default or at least have this option for serial always in GRUB?

I have also not selected the serial option in my test above to see if the APU detection still works. This is running after the partition resize and should always enable the serial console on apu1-4. (Depending from the Flash it can need some Minutes without any output.)

Maybee you have an very old bios on the APU that not set the correct Manufacturer/Board ID
I have tested with 4.9.x.x and also 4.10.x.x (but with 4.10 there is a bug in the LED config).

1 Like

ok, tested with a new device and the serial-option appears from the first boot. After selecting this, it works like expected.
Maybe i was just too impatient the other times when i didn’t select/see the serial option in the GRUB menu.

hi guys need help, for the version IPFire 2.25 - Core Update 145.
i dint find any option for serial installation…please advise, thanks

i dint find any option for serial installation…please advise, thanks

Please refer to Michael’s first post in this tread.

Same Problem,

boot and no option with Serial Console.
So i can´t install.

Bildschirmfoto 2020-10-06 um 13.12.09 !

Hello Mathias,

please use an actually image. Ipfire 2.21 is very old. https://www.ipfire.org/download/ipfire-2.25-core149 is the latest stable version.

Then on first boot you should have an option for serial console.

1 Like

Hey, thank you, but is it still the same with 2.25 - no Serial output available Bildschirmfoto 2020-10-07 um 09.18.52

You have bootet the Instalation ISO in uEFI mode. In this mode the output is choosen by the uEFI Bios and it is not needed to configure the serial output.

In Legacy Mode the flashimage and also the Install Iso has a option to enable serial output.

1 Like

Hey Arne, thanks that was the Solution. But now i have this Problem, do you have a idea how to fix?

try to close and reconnect without rebooting the target system. (I think the terminal has git some wrong characters that switch the charset.) after reopen the serial line use cursor up and down to find the correct menu.

Or try an other terminal program. (IPFire use UTF-8)