DOWNLOAD ERROR: The downloaded file (2.25-x86_64/lists/server-list.db) wasn't verified by IPFire.org. Sorry - Exiting

I just installed IPFire on an x86_64 AMD PRO A10-8770E and everything is working very well except that I can’t update pakfire. Here’s what I see:

[root@pacifica lists]# pakfire update
server-list.db       100.00% |=============================>|    2.30 KB
DOWNLOAD ERROR: The downloaded file (2.25-x86_64/lists/server-list.db) wasn't verified by IPFire.org. Sorry - Exiting...
TIME INFO: Time Server 66.220.9.122 has -0.049289 sec offset to localtime.

It also doesn’t work in the web interface. Here’s what I have tried:

  • I’m able to ping pakfire.ipfire.org.
  • I downloaded this key and imported it with gpg --homedir /opt/pakfire --import key.asc successfullly
  • I ran /etc/init.d/pakfire start
  • Ran gpg --homedir /opt/pakfire/ --keyserver pgp.ipfire.org --always-trust --status-fd 2 --recv-key "3ECA8AA4478208B924BB96206FEF7A8ED713594B" successfullly
  • Ensured that the /opt/pakfire dir and underlying files had the correct gpg permissions

Here’s what I see when I check my keys:

[root@pacifica opt]# gpg --homedir /opt/pakfire/ --list-keys
/opt/pakfire//pubring.gpg
------------------------- 
pub   4096R/D713594B 2018-03-16
uid                  IPFire Pakfire Package Signing Key <pakfire@ipfire.org>

But I still see the error above. Is there anything else I can try?

Do you also have a pakfire-2007.key in /opt/pakfire ?

My /opt/pakfire/ looks like:

[root@ipfire ~]# ll /opt/pakfire/
total 44
drwxr-xr-x 6 root root 4096 Dec 26 18:39 .
drwxr-xr-x 3 root root 4096 Sep 18  2019 ..
lrwxrwxrwx 1 root root   23 Sep 18  2019 cache -> ../../var/cache/pakfire
drwxr-xr-x 7 root root 4096 Oct 31  2019 db
drwxr-xr-x 3 root root 4096 Mar 18  2020 etc
drwxr-xr-x 2 root root 4096 Jun 19  2020 lib
lrwxrwxrwx 1 root root   21 Sep 18  2019 logs -> ../../var/log/pakfire
-rwxr-xr-x 1 root root 9315 Sep 18  2019 pakfire
-rw-r--r-- 1 root root 1814 Sep 18  2019 pakfire-2007.key
-rw-r--r-- 1 root root 1648 Sep 18  2019 pakfire-2018.key
drwxr-xr-x 2 root root 4096 Dec 26 18:44 tmp

Thank you for the quick response Paul! Here’s what I see under /opt/pakfire:

/s/opt/pakfire λ ls -l
total 31
lrwxrwxrwx   1 root           root       23 2020-12-18 04:39 cache -> ../../var/cache/pakfire
drwx------   7 root           root     4096 2020-12-26 14:38 db
drwx------   3 root           root     4096 2020-12-26 14:19 etc
drwx------   2 root           root     4096 2020-12-18 05:43 lib
lrwxrwxrwx   1 root           root       21 2020-12-18 04:39 logs -> ../../var/log/pakfire
-rwx--x--x   1 root           root     9315 2020-12-18 04:39 pakfire
-rw-------   1 root           root     1814 2020-12-18 04:39 pakfire-2007.key
-rw-------   1 root           root     1648 2020-12-18 04:39 pakfire-2018.key
-rw-------   1 root           root     1161 2020-12-26 18:34 pubring.gpg
-rw-------   1 root           root        0 2020-12-26 18:24 pubring.gpg~
-rw-------   1 root           root        0 2020-12-26 18:32 secring.gpg
drwx------   2 root           root     4096 2020-12-26 14:44 tmp
-rw-------   1 root           root     1200 2020-12-26 18:24 trustdb.gpg

Here’s the hashes for my pakfire key files:

/s/opt/pakfire λ md5sum pakfire-2*.key
b291fae932c884c2c13193e638df5f8d  pakfire-2007.key
1c42a6a8435dc9d924a29c5cdd848cf6  pakfire-2018.key

I suggest remove (or mv them to save/ dir) pubring.gpg, those 2 files with 0 bytes and trustdb.gpg so that your dir matches mine. The md5sums match what I have. Then, pakfire update My output:

[root@ipfire ~]# pakfire update
server-list.db       100.00% |=============================>|    2.35 KB
packages_list.db     100.00% |=============================>|    4.85 KB
core-list.db         100.00% |=============================>|   903.00 B
[root@ipfire ~]#

I noticed the pakfire file (in /opt/pakfire/, it’s a perl script) does not have the same perms as mine (missing r for group,others). … seems the perms in /opt/pakfire/ are different than mine. Can you go through each line and fix them, all of them?

Oh duh, yes, I’ll try that now!

Ok, it’s fixed! Here’s what I needed to do:

  1. Grab a pristine copy of the /opt/pakfire dir from the .img file that I downloaded.
  2. Rename the /opt/pakfire dir on my router to /opt/pakfire.orig
  3. Copy the pristine pakfire directory in it’s place
  4. Run /etc/init.d/pakfire start

Now the updates work! Thank you again @pavlos for the help!

1 Like

For your information, I think I’ve found a simpler solution without using command lines.
Go to the web interface > IPFire > Pakfire.
In the Settings box, click on “Save” without changing the current repository setting.
Then I was able to apply my updates successfully.