DNS stop resolving after activating DHCP service

Hi there,

excuse my poor English.

I’ve been working with IPFire for many years. Thanks a lot for your work. Until yesterday, everything was fine. I’ve got this very simple configuration where IPFire routes:

  • a virtualbox machine being “router” with IPFire core 141; with a red network card connected to internet (NAT) and a green card connected to internal network with IP 192.168.100.1

  • a virtualbox machine being client in internal network with static IP 192.168.100.2.

It have been working for a while, but yesterday I decided to activate the DHCP service in IPFire, and configure the client to receive IP. It worked, but at the same time DNS resolving stop working in client and in IPFire. Both can ping a IP in internet, but they can’t ping a name in internet.

The only change I saw is that before activating DHCP service , the IPFire resolv.conf file contained 192.168.100.1, that was the IPfire green card IP, but after activating the DHCP service in IPFire, the IPFire resolv.conf file suddenly contained 127.0.0.1.

Then I tried a new fresh IPFire install with last core 144. But the same trouble appeared when activating the dhcp service.

Just changing the IP in the resolv.conf file from 127.0.0.1 to 192.168.100.1 makes DNS resolving work for a while.

What I am doing wrong? I am just activating DHCP service.

Thanks

The /etc/resolv.conf should always contain only the localhost (127.0.0.1) to use the internal unbound cache. Go to Domain Name Service config page and enter working servers for unbound.
https://wiki.ipfire.org/configuration/network/dns