DNS resolution does not work, DNS proxy server is stopped

Hello, my IPFire doesn’t trigger DNS queries anymore, this happened suddenly. So “nobody gets on the Internet anymore”.
So far the hardware seems to be fine, the software also runs and I reach the web interface.
As “root” on the IPFire on the console, I can successfully ping ip addresses, not domains. For example works, but not heise.de
With a “dig” command I can get a name resolution e.g. via the DNS server from google.

Via the web interface I can see that the DNS proxy server is “stopped”. AFAIK I didn’t do that.
When booting IPFire I see that the unbond cannot be started: “[1574362329] unbond-controll [1465:0]error:connect: Connection refused port 8953”.

How do I fix IPFire so that everything works?

It’s old hardware with old hard drive. Can a hard disk failure cause something like this?

Thanks for replying,


Translated with www.DeepL.com/Translator

Is there anything in /var/log/messages?

Today, Monday, I have physical access to the machine again.
It’s a bit strange: after the first login as root I could change to the specified directory and list all files in it with “ls”, it was more than fits on a screen.

Because I know the shell commands only rudimentarily, I switched to a PC with internet access to find out how to list them screen by screen. I was also further held up by colleagues.
When I returned to IPFire, “root” was logged off “bye-bye” probably due to time-out.
After logging in again, the “cd” command only returned the message that there was no directory “/var/”.

Then I shut down the IPfire completely and restarted it. It was the same as in the 1st post, after which the “unbound” could not be started.

However, there is still no directory /var/ I could change to.

It seems to be an interesting problem, but the internet should work again this evennig, otherwise a course at this Volkshochschule will be cancelled…

the problem is solved, I completely reinstalled IPFire.
Thanks to the timely data backup no problem.