Dns.cgi missing from menu

It seems that if I configure RED as DHCP, there is a DNS.cgi (Network>Assign DNS server) where I can define my own DNS entries but if I configure RED as static (a test ipfire), DNS.cgi does not appear in the menu and the only way to configure is to log on to the konsole and run setup. Is this by design?

Hey,

when you are using RED in STATIC mode, you cannot use the CGI, but need to change DNS servers in the setup menu where you changed from DHCP to STATIC.

This is very unintuitive and we are working on changing that soon.

Thank you.

Hi everyone

How would one go about overriding the ISP DNS servers. I need to keep my connection settings as DHCP but manually specify other DNS servers.
I am also missing the Network>Assign DNS server menu.

@brendonb if RED is configured DHCP, you should have Network > Assign DNS servers but if RED is configured static, you have to run setup from the console to set your DNS entries.

@pavlos - Thanks for the reply
Sorry should have clarified - my setup is PPPoE (not Static or DHCP) for red.
Attaching screenshots of “Network Menu” which does not have the “Assign DNS”

I dont have PPoE so (as a suggestion) if you log on to console and change DNS entries, reboot, does the gui show your selections?

If I go to setup and then “Network Configuration” and “DNS and Gateway Settings” I see the attached.
It shows my Primary DNS as the local Ethernet IP of the Green interface. If I try and change this to the third party DNS providor then all connectivity fails. It does not reflect the new IPs in the GUI.
I think this may be a bug?

looks like a bug since on those 3 lines I have 1.1.1.1 1.0.0.1 10.0.0.1 (my local network).

@pavlos - Thanks very much - will look at logging it as such. Out of interest which version are you running? I am running core 138.

core 138 as well.

@brendonb clients using DHCP won’t be aware of the change of DNS and appear to lose connectivity. Rebooting those might fix the problem.