Disabling LEDs on RPi 3B+ trough /boot/config.txt not working

I want to disable the LEDs of my IPFire installation on an RPi 3b+, but I can not get it to work trough adding the following to /boot/config.txt:


I am using the latest core176 build. This works on the standard Raspberry Pi OS. For those who have looked into this on RPi before, there are some back and forth on what parameters you need to turn off the Power and Activity LEDs depending on exact kernel (6.2 will fix this btw)

But the network LEDs should have been turned off regardless.
It’s as if the dtparam entries does nothing or arent even parsed.

There are no topics on this AFAIK. Has anyone looked into it ?

The “dtparam” is indeed not parsed by u-boot/mainline kernel which is used by IPFire.

Raspberry Pi OS use a hacked kernel which is booted by the firmware.

1 Like

Ok, thanks for letting me know! I figured out that

echo 0 | tee /sys/class/leds/PWR/brightness
echo 0 | tee /sys/class/leds/ACT/brightness

will turn off the power and activity lights. But I am not sure how to do the LAN leds yet, seems a bit different. Then i’ll make a shell script and try to find a sensible place to run it from on system boot.

I’ll post again if i figure it out, unless someone does it first :slight_smile:

1 Like
1 Like

possibly it is not the CPU but the ethernet chip that controls the leds behavior.