DHCP wui Not working. core 144

Can not change primary DNS from Wui.

Could be a bit more specific, please?
What do you want to configure?
Any error messages?

Wanted to move back to router at
Primary DNS when changed in Wui from to it will not change.
I will have to run setup to change if Wui will not work.

I’ve just tried.
A change in the WUI shows up there.
After a renew of the IP on a client the new information is set on this client.

Did you disable the interface to do so?

I disconnected and reconnected the device.
For this special test ( my Windows laptop on Blue ) I disconnected the wireless connection and connected again to the IPFire AP.
If you want to test those changes more easily, just temporarily set your lease time to a very short time ( 1 min ). Thus your client just tries every minute to get a new lease and should get the new config also.

Can’t change lease time!
Disconnect all devices on green or red?
Am sure the devices on green will pickup the new settings.
But the Wui never takes the changes.
Do I have to remove all traffic from Ipfire to make change?

Did you click “save”?

@hvacguy from the console
/etc/init.d/dhcp stop
/etc/init.d/dhcp start

Yes save did not work.
Should I stop dhcp
Then change Wui
Restart dhcp?

Any error messages?
In /var/log/messages or on the console, if you do a manual restart (dhcp stop / dhcp start ).

Could not log into console? Password did not log me in?
logs will not come up in Wui
Could not stop openvpn from Wui.
Wui broken. hopefully I can make a backup and reinstall this weekend.
Log should be on my Syslog server

Basically, you should have direct access to the console of your system!
My system has the console on a serial connection. This device is the basic interface of the system at boot. The standard PC environment uses monitor/keyboard.
This interfaces needs minimal ressources, allowing a maintenance of difficult situations.
All tools based on networking ( SCP/FTP, remote logging ) are nice additions, that make live easier but do not help in every situation.
Looking at your problem shows this is essential!

How did you nstall your system?
Where? On “bare metal” or virtual?
How did you setup your interfaces?
Have you tried just a restart of the system, sometimes this repairs problems in the network config.

Basically, you should have direct access to the console of your system!
password was not working.
Have you tried just a restart of the system, sometimes this repairs problems in the network config.
yes Hard reboot.
Where? On “bare metal” or virtual?
bare metal HP T620 plus
How did you setup your interfaces?
dhcp was
changed it in the past to
but I belive i Have a Wui problem.
It is not just that setting that is not responding.
backup doesn’t work
Openvpn will not stop.
Will probably reinstall from thumb drive and restore latest backup.

Good news. browser fire fox not working!?
Chromium works!
happy to find not an Ipfire problem.
working now
It was a browser plugin. removed and problem gone.
Firefox working now

1 Like

What firefox plugin made the trouble? Knowing this can help other users.

Now you should solve your problem with the console/shell access. As stated above this is essential to manage a possibly broken system.

Not a common one

And also not trivial one. :wink:
Proxy settings, bookmarks, security settings can be changed by this addon. Means without special config you can loose connection to all destinations not belonging to the I2P net, which can include your local network with e.g. IPFire.
Thus my recommendation of an easy access method which doesn’t need much resources.
BTW: you should have defined your root password at setup.