DHCP server not accepting wpad in advanced options

Hi All,

I’ve run into a small bit of an issue while trying to setup proxy setting discover via DHCP.
I can manually add the wpad options to the dhcp.conf file but I’d rather edit these options in the GUI. Any help would be much appreciated :slight_smile:

Hello Donal - Welcome to the IPFire Community!

There are a few pages in the IPFire Wiki that may help:


Hi Jon,

Thanks for the response. Unfortunately those were the guides I was following. The proxy itself works properly, I’ve tested that, the problem lies in the web interface not recognizing “wpad” as a valid option name in the additional DHCP options section, despite it being listed in under the “List options” button.

What’s also curious is that dhcp.conf recognises them to be valid, and has in-fact worked, but any changes would require me to go in via the terminal which is less than ideal given there’s an interface for that.

Are you trying to do something like this? Or different?

Or you did the above and it didnt work?

I tried doing whats in the picture, but it tells me that wpad is not a valid option name.

Hi @dodelathon

As @jon showed in his picture you need to first enter

Option name:  wpad                   Option value:   code 252=text

Then enter

Option name:  wpad                   Option value:   "http://www.server.fr/path-to/proxy.pac"

If you just try to put in the second command only then you will get the error messsage that the wpad command is not known.


Yup that did it, Sorry @jon I completely misinterpreted that order of the options made a difference :sweat_smile:.
Thanks a million guys, I’ma mark this as solved!

1 Like

I see your problem.
You must not know the internals of the DHCP server. The WUI allows you to configure in a ‘intuitive way’. On the other hand to define advanced options you should know these details.
Maybe it could help to rearrange the text in the wiki to make it clearer and consistent.
Thanks for showing this problem. I’ll try to edit this wiki article.