DFS region 0x0 not supported, will trigger radar for every pulse

Hi,
after updating my apu2 with Compex WLE600VX for wlan to IPFire 2.23 - Core Update 138 my wlan do not work any more.
After diging around, i find a hint in System Logs:

21:21:45 kernel: ath10k_pci 0000:01:00.0: DFS region 0x0 not supported, will trigger radar for every pulse
21:20:30 kernel: ath10k_pci 0000:01:00.0: DFS region 0x0 not supported, will trigger radar for every pulse
21:16:40 kernel: ath10k_pci 0000:01:00.0: DFS region 0x0 not supported, will trigger radar for every pulse
21:10:22 kernel: ath10k_pci 0000:01:00.0: DFS region 0x0 not supported, will trigger radar for every pulse
21:10:06 kernel: ath10k_pci 0000:01:00.0: DFS region 0x0 not supported, will trigger radar for every pulse
20:58:03 kernel: ath10k_pci 0000:01:00.0: DFS region 0x0 not supported, will trigger radar for every pulse
20:58:01 kernel: ath10k_pci 0000:01:00.0 blue0: renamed from wlan0
20:58:01 kernel: ath10k_pci 0000:01:00.0: htt-ver 2.1 wmi-op 5 htt-op 2 cal otp max-sta 128 raw 0 hwcrypto 1
20:58:01 kernel: ath10k_pci 0000:01:00.0: board_file api 1 bmi_id N/A crc32 bebc7c08
20:58:01 kernel: ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/board-2.bin failed with error -2
20:58:01 kernel: ath10k_pci 0000:01:00.0: firmware ver 10.2.4-1.0-00037 api 5 features no-p2p,raw-mode,mfp,allows-mesh-bc ast crc32 a4a52adb
20:58:01 kernel: ath10k_pci 0000:01:00.0: kconfig debug 1 debugfs 0 tracing 0 dfs 1 testmode 1
20:58:01 kernel: ath10k_pci 0000:01:00.0: qca988x hw2.0 target 0x4100016c chip_id 0x043222ff sub 0000: 0000
20:58:01 kernel: ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-6.bin failed with error -2
20:58:01 kernel: ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/cal-pci-0000:01: 00.0.bin failed with error -2
20:58:01 kernel: ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:01: 00.0.bin failed with error -2
20:58:01 kernel: ath10k_pci 0000:01:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0

So it seems, there is a problem with the WLE600VX?!

If i try “iw reg get” on the console i get this:
global
country DE: DFS-ETSI
(2400 - 2483 @ 40), (N/A, 20), (N/A)
(5150 - 5250 @ 80), (N/A, 23), (N/A), NO-OUTDOOR, AUTO-BW
(5250 - 5350 @ 80), (N/A, 20), (0 ms), NO-OUTDOOR, DFS, AUTO-BW
(5470 - 5725 @ 160), (N/A, 26), (0 ms), DFS
(5725 - 5875 @ 80), (N/A, 13), (N/A)
(57000 - 66000 @ 2160), (N/A, 40), (N/A)

phy#0
country US: DFS-FCC
(2402 - 2472 @ 40), (N/A, 30), (N/A)
(5170 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
(5250 - 5330 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
(5490 - 5730 @ 160), (N/A, 23), (0 ms), DFS
(5735 - 5835 @ 80), (N/A, 30), (N/A)
(57240 - 71000 @ 2160), (N/A, 40), (N/A)

This Card hase a “global” Section with the right settings.
And a phy#0 with country US: DFS-FCC.

How can i change phy#0 to DE: DFS-ETSI and do not loose this setting?

Best Regards,

Dieter

I don’t think so. I’ve got the same problem and here also: GREEN DHCP server is assigning IP addresses to WI-FI devices

Hi Terry, that seems to be an other problem, i have upgradet the IPFire to core 139 and the problem stays.
Do you have the dhcp fore the blue0 interface correct?
In my case, green0 was 10.220.10.0 and blue0 was 10.220.30.0, so evrything works perfect until this error.

3 days ive try to solve the pr,oblem, than i pull out the card and use an other router for local wlan.
Now i have a second WLE600VX Card, if i find some time, i will try if the problem stay also with the second card.
Best regards,

Dieter

I only mean the problem, that whatever you define for your country code, the DFS error message still exists.

Many channels doen’t work for me. Pls. try yours. Maybe that’s your problem as well:

IPFire perfectly supports DFS. Using this with my IPFire box for over a year now. But finding hardware that agrees with it is difficult.

Is this related to the base/motherboard or the wifi module?

Only Atheros chipsets using the ath9k or ath10k drivers support this. If you consider buying a WiFi module, don’t buy anything else but that.

But the chipset uses the ath10k driver… so it should work, but doesn’t.

Well, I am not sure if there is firmware out there that has this disabled. I know that they ship those modules locked down sometimes for the US market.

That’s something I could find on the net as well and tried that already (country code/ID US) but it didn’t change anything. I tried several country IDs. The point is: does that behaviour hurt me or not?

i dont know exactly - but you can try to search your serial number on the support page and documentation for firmware/release notes etc.

  • A Qualcomm Account is needed to access the Documentations… :confused:

Hi,

my card believes that it belongs to the US, too, but I could set the kernel to GB:

[root@fw01 ~]# iw reg get
global
country GB: DFS-ETSI
	(2402 - 2482 @ 40), (N/A, 20), (N/A)
	(5170 - 5250 @ 80), (N/A, 20), (N/A), AUTO-BW
	(5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS, AUTO-BW
	(5490 - 5710 @ 160), (N/A, 27), (0 ms), DFS
	(57000 - 66000 @ 2160), (N/A, 40), (N/A)

phy#0
country US: DFS-FCC
	(2402 - 2472 @ 40), (N/A, 30), (N/A)
	(5170 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
	(5250 - 5330 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
	(5490 - 5730 @ 160), (N/A, 23), (0 ms), DFS
	(5735 - 5835 @ 80), (N/A, 30), (N/A)
	(57240 - 71000 @ 2160), (N/A, 40), (N/A)

The relevant part of hostapd.conf looks like this:

country_code=GB
ieee80211d=1
ieee80211h=1
channel=- Automatic Channel Selection -
hw_mode=a
ieee80211ac=1
ieee80211n=1
wmm_enabled=1
ht_capab=[HT40+][HT40-][TX-STBC][RX-STBC][SHORT-GI-20][SHORT-GI-40][MAX-AMSDU-7935]
vht_capab=[MAX-MPDU-11454][RXLDPC][SHORT-GI-80][TX-STBC-2BY1][RX-STBC-1][MAX-A-MPDU-LEN-EXP7][RX-ANTENNA-PATTERN][TX-ANTENNA-PATTERN][BF-ANTENNA-2][SOUNDING-DIMENSION-2][VHT-LINK-ADAPT3]
vht_oper_chwidth=1

According to lspci it is this model:

03:00.0 Network controller: Qualcomm Atheros QCA986x/988x 802.11ac Wireless Network Adapter

-Michael

1 Like

Hm I don’t have that at all. I just get the global/set information.