Deleted host still show in group

we have removed a host from a network group on our IPFire.
Now the host is still highlighted in yellow. See attached screenshot.
Does this affect the firewall rules? How do we get rid of this host?

Thanks for help.


If I enter an existing network into a network/host group and then press the dustbin icon for that network entry it is just deleted with no problems.

The only way I was able to reproduce your effect was the following.

  • Create a network name in the network group.
  • Then add that network name to an existing network/host group.
  • Then go back to the network group. You can not delete the network entry there as there is no dustbin icon due to the fact that the host is being used. There is a 1x in the Used column. However if you select the edit pencil for that host entry and then clear the entries from the four boxes in Add new network and then press the Update button, the network entry is then removed from the network group.
  • Now go back to the network/host group page and you will see the yellow line you have indicated.

If a network or host entry is being used you need to first remove that entry from where it is being used. Then the network or host entry in the network or host group page will show 0x in the used column and the dustbin icon will be present allowing you to now delete that network or host.

To get round this in your situation, you need to go back to the network group page that would originally have held the network entry and re-create it the same as it originally was.
Then the entry in the network/host group will show it being used.
Then delete the entry in the network/host group by pressing the dustbin icon.
Then you can go back to the network group and there will now be a dustbin icon for that entry unless it is also being used elsewhere, such as in a Firewall Rule.
In that case find the firewall rule that is using that network definition and delete it.
Keep doing this until the used column for that network entry has 0x against it. Then the dustbin icon will re-appear and the network entry can be deleted.



Great, that was the solution!
I don’t know how my colleague deleted the entry,
but the procedure to undo it and delete it worked correctly!
Many thanks for the quick help.

Glad you could get it solved.

I will try and have a look at the code as it should really prevent an edit from clearing all the entry boxes.


Had a look at the code and found that a check is done if the fields are all filled in if a new entry is being saved but not if an edit of an existing field is being done.

Looks reasonably easy to just include that same check in the edit section for the network.

Will also check the other groups to check that empty entries are not accepted.