DDNS with Namecheap fails


Pardon if I post in the wrong spot or other mistakes, it’s my first go here.

I’m having trouble getting my IPFire (2.25 (x86_64) - Core Update 154) DDNS Service to work with my domain and provider, Namecheap. In the IPFire DDNS settings on the WebGUI I’ve entered: Namecheap from the dropdown menu and ticked the “enabled” box. I put then domain into the Hostname and Username fields, and the DynamicDNS Password Token supplied by Namecheap in their interface and hit Add. After reloading the DDNS entry shows up in Current Hosts at the bottom, however it does not work. The log entry on IPFire says “Domain not found” (more below).

After realizing it wasn’t working, I spent some time on the Live Chat with Namecheap where they confirm (as best they can) that things are working on their end.

I’ve messed about and tried a lot of combinations of possible inputs on the WebGUI to no avail. I eventually found this link https.wiki.ipfire.org/configuration/services/dyndns_providers (sorry new user so 1 link per post) which is the setup/guidance I’m currently using, but does not work.

Here is the log I got when I tried to debug force update the DDNS after ssh’ing into IPFire (my details changed):
Loading configuration file /var/ipfire/ddns/ddns.conf
Updating somesillydomain.org forced
Sending request (GET): https://dynamicdns.park-your-domain.com/update?ip=x.x.x.x&password=AAABBBCCCTTTOKEN&host=somesillydomain&domain=org
Request header:
User-agent: IPFireDDNSUpdater/013
Pragma: no-cache
Response header (Status Code 200):
Cache-Control: private
Content-Type: text/html
Set-Cookie: SOME-COOKIE; path=/
Date: Thu, 11 Mar 2021 15:06:03 GMT
Connection: close
Content-Length: 423
Logging failed update for somesillydomain org: DDNSRequestError: Request error
Opening database /var/lib/ddns.db
Dynamic DNS update for somesillydomain org (Namecheap) failed:
DDNSRequestError: Request error
Domain not found

Edit: Log only edited to change my stuff and get around the 1 link per new user restriction on the forum.

Hi tw, I am also using namecheap for my dynamic DNS, it does work but the way to set it up is a little confusing due to namecheap.

on the hostname section put in your full host name example = host.domain.com

The username and password is what got me.
The password hash namecheap.com gives you goes into both username and password fields.

This should work for you also.
Please reply if it works.

You’re a hero among mere mortals HomeRcide!

Thank you :slight_smile:

-tw out

Great !
Did I earn another cup of morning coffee?

1 Like

Based on your input I have updated the wiki entry for namecheap.com


1 Like

I forgot that was even in the wiki or missed it entirely, it was around 6 years ago or more I fought with the same issue.

Thanks, that should keep a few people from pulling their hair out.