CUPS not printing test page

I installed CUPS using pakfire and added a network printer (Sharp MX-M264-N). But when I tried to do a test print from admin interface, nothing is getting printed. Hwo can I troubleshoot, what went wrong?


Do you have the .ppd file loaded for the printer?

Yes, during the printer installation I have added the specific .ppd file.

It has bin so long since I have set up CUPS.
I can’t remember my password.? It just works.
I do remember having allot of trouble getting the settings right.
And deleting printer and starting over till i got it right.
Sorry I’m of little help here.

From the web interface, go to the jobs tab - are any listed ? A reason is often provided for any stalled jobs.

Most web interfaces to CUPS also provide access to the CUPS error log, but IPFire’s implementation does not.

From the console, as root, check in /var/spool/cups. Completed jobs are likely to have only a meta-data summary. Uncompleted jobs have a larger file per job, containing the whole job. I’m not aware of what sub-directory IPFire would put the latter in. If there are any job files, then CUPS appears to be working but the printer is not found. If there are no job files then CUPS processing is failing - this can require much troubleshooting - yet it could be as simple as paper size mismatch.

I’ve never tried printing the test page. Does a real page, from (say) a text editor print ?