CUPS - can't add printer

I just installed cups and hplip to add my printer to the spooler.
Neither the with root credentials nor with a new user for the “lp” group the new settings were accepted.
root-account: CUPS webGUI login didn’t worked
user account: CUPS webGUI login accepted, but adding printer forbidden

Did I missed something important about configuring the access rights in the wiki?

My IPFIRE is running core update 162

Thanx a lot for valuable your time and help

Permission to add printers varies with Operating System. What OS are you running your browser from ?

I know. But I’m trying to add my printer to the CUPS server running on my IPFIRE.
And got stuck here with permission probs although I created a user within the “lp” group or even tried the root login (according the ipfire cups wiki).

If the printer is added to the server I can dig into the clients :slight_smile:

1 Like

Glad you got things working with a new “lp” user/group!

I am using core update 162. And I just installed CUPS and added a new printer. Using the “root” as the ID and the IPFire box root’s password (created during IPFire setup) worked for me. I am not sure why it did not work for you.

No, I didn’t got it working until now. But as you managed to add a printer, it must be an individual problem :frowning:
Will dig into it with a second test install.

If you open CUPS local URL localhost:631, there is significant help, particularly manpages and use of the underlying “lp…” command line tools. I have used such, in earlier times, to add printers to a headless server. All must be done a root, unless permissions are modified in /etc/cups/cupsd.conf, which I don’t suggest.

Note that CUPS must be stopped before modifying config files.

1 Like