Couldn't access the admin WUI

Hey you all,

I want to add a raspberry pi on my home network and create a safe (green) subnet to have my devices separated from the main network and play around the various options IPFire can provide.

My main router operates on

I’m using a PI4 Model B and downloaded the IPFire 2.27 - Core Update 167
I used the PI IMAGER to format the SD Card and edited the serial console to OFF.

My network setup:

Red0 is assigned to an ethernet cable linked to my main router:

Green0 is assigned to a wireless network card with USB:
→ Address:
→ Netmask:

DHCP enabled on Green0 with the following settings:
→ Starting Address:
→ Ending Address:
→ Primary DNS:
Rest are default.


what i tried and what i noticed so far:

1_ Rebooted everything (PC, main router, PI) multiple times in different order with no results.

2_ Console cannot ping main router neither any device on green network.

3_ Both Red0 and Green0 show the (NO-CARRIER) when using the command ip a.

4_ Changed the IP address of my PC manually to a static IP on the same subnet as the PI4 and still
no answer from the WUI.

5_ Tried to connect 2 USB wireless network cards instead of relying on the ethernet cable as Red0
with no success.

6_ Verified that all cables, network adaptors, and the SD card function properly.

7_ Reinstalled the IPFire many times with different versions.

8_ Tried the STATIC option instead of the DHCP on Red0 with the following configuration:
→ IP Address:
→ Netmask:
→ Gateway:

 with no success unfortunately.

9_ Reinstalled the IPFire on PI4 and only assigned Green0 as the only network interface on PI4
ignoring the Red0 and tried to access the WUI with no success.

10_ Switched between interfaces having the USB wireless interface act as the Red0 and the ethernet
cable as Green0 to try and reach the WUI from the main subnet with no luck.

11_ Tried using Ethcher to flash the Operating System instead of the PI Imager and went through the
whole process again. no success.

12_ DHCP never actually worked. (No IP addresses were assigned to devices from the specified


At this point i feel like i exhausted all the potential configurations that can be applied on the network configuration page (or on the setup command), i visited a lot of websites, followed the installation guide step by step, read a lot of topics on different forums, and reached the bottom of the least watched videos on YouTube.

I’m pretty sure there is something i missed however, simply because that’s always the case for me haha. and yes i know some of my test were unnecessary, but i tried to cover everything i could think of for the last few days.

Feel free to ask literally anything even the most basic stuff.


1 Like

That should work. Connect to new Green network and https://192,168,60,1:444
should bring up WUI.
Not familiar with Pi or WIFI setup in IPfire
Not sure what you are referring to by main subnet.
good luck not sure if that helps.

hey, sorry for my unclear explanation.

The main subnet is the subnet of my router (

Thank you for your time.

Let’s check first if you are making a connection via your red interface or not.

What are the contents of your /var/ipfire/dhcpc/ file

Hello there,

I checked the file and it is empty.

So that means that you have not achieved any connection to your router.

Look in the WUI menu under Logs - System Logs and then select RED in the drop down box and select All for the Day setting and press Update.

This will show you the log messages for when the attempt was made to connect to the router and get an IP Address etc via dhcp.

Please show the contents of this log. There shouldn’t be any sensitive info in it as your connection is to the router with a private non-routable subnet.

I would’ve but the problem is i cannot access the WUI in the first place, is there any way i can get you the information you need using the command prompt?

If you have access to the command line, you can try elinks.

Below are sample screenshots from the test VM




The visible data can be exported and saved to a file.





Yes, there is. the info will be in /var/log/messages if you rebooted today so that IPFire tried to make a connection to red.
If it was earlier than today then you will need to look in /var/log/messages.1.gz and so on. Each incremented gzipped file is a day earlier than today.

As there is a lot of data in the file you will need to filter out the required info.
For todays file use
grep dhcpcd /var/log/messages

For gzipped files use
zgrep dhcpcd /var/log/messages.1.gz
replacing 1 with the appropriate number for when you rebooted last.

1 Like

Here is the logs for Red0 extracted using the method mentioned by @tphz thanks a lot man !!


               ipfire.localdomain - System Logs (5/5)

12:33:44 dhcpcd[1819] : sandbox unavailable: seccomp

12:33:44 dhcpcd[1819] : red0: waiting for carrier

12:34:44 dhcpcd[1819] : timed out

13:05:55 dhcpcd[1684] : dhcpcd-9.4.1 starting

13:05:55 dhcpcd[1687] : sandbox unavailable: seccomp

13:05:55 dhcpcd[1687] : red0: waiting for carrier

13:06:55 dhcpcd[1687] : timed out

13:36:10 dhcpcd [3147] : dhcpcd-9.4.1 starting

13:36:10 dhcpcd [3150] : sandbox unavailable: seccomp

13:36:10 dhcpcd[3150] : red0: waiting for carrier

13:37:10 dhcpcd[3150] : timed out
Older Newer

I would only expect to see this if you had installed the tor addon as seccomp is a dependency addon for tor and would not be installed as a standard installation of IPFire.
I am not sure it would cause a problem here or not.

It might be worth trying to uninstall it from the command line.

pakfire remove tor
pakfire remove seccomp

This means that IPFire was waiting for a signal on red and nothing was there and so it eventually timed out.
Likely causes for this are that the network cable from your router is not plugged into the red port on IPFire or that your router is not set up to provide dhcp service to machines on its ethernet port.

unfortunately i couldn’t remove the package simply because pakfire requires internet connection to proceed my commands, i also want to mention that i installed the latest version from the following URL:

As for the wrong ethernet port, as i mentioned earlier i use a PI4 Model B which only have a single built-in ethernet port which of course in this case is assigned to Red0.

The router assigns IP addresses to devices connected to ethernet ports simply because when it is connected to my PC i get an IP Address and i am able to effectively ping devices on the network (using the same LAN cable i use in my PI4 Model B tests right now).

Lastly i want to add that i noticed when connecting the LAN cable to my PI4 Model B, only the brown led is on. The green led on the other hand, lights up momentarily after using the Identify button in the Network Setup page.

Of course. Sorry my fault.

I am running out of ideas.

There were issues with the RPi4 B especially with regard to certain build versions but those cause problems even to get the Pi to start up properly.
You have got it to the stage of installing but then the red connection is not receiving any communication from the router. I don’t have any more ideas on what to look for.

Maybe other forum people using the RPi4 B will have further ideas.

Its fine don’t worry about it, one more thing tho
do you know other forums to ask about this particular issue ?

Hi again,

I want to report that i eventually pointed out the problem and fixed the issue took me a week though. Now i am able to proceed with my small project.

And for the issue, i was consistently choosing the wrong interface (choosing the wireless card interface instead of the ethernet interface), i was searching every corner of the operating system and never though that i might have missed something so basic from the very beginning. Made one mistake at the start and took for granting that i couldn’t have made such mistake.

Thanks to all who tried to help !!