Core149 on an ALIX (i586)

I know i586 HW is deprecated now. :wink:
Nevertheless I hoped to use my good old ALIX board some months longer. ( To chose and order a replacement I need my IPFire appliance, for example).

Today I tried to update to core 149. After struggling with the memory size limitations, I finally succeeded. But after the update I got many traps “invalid op code”, also after reboot!

A fresh install of core 148 was successful. Most of my family uses WLAN, thus the first addon I installed was hostapd, to shorten the internet down time.
Activating the AP gives the error
traps: wlanapctrl[12454] trap invalid opcode ip:8049420 sp:bfc84c90 error:0 in wlanapctrl[8049000+1000]

Is the actual hostapd module compiled with the libs for core149 ( not functioning with my HW )?
If yes how can i get the “old” module, which worked?

EDIT: Opened a bug in bugzilla.

1 Like


EDIT: Opened a bug in bugzilla.

just for the records: Could you mention the ID of that bug here?

Thanks, and best regards,
Peter Müller

Sorry. It is

1 Like

If I had known you wouldn’t edit your posting, i had done this job for you yesterday :stuck_out_tongue_winking_eye:

I think what Peter meant is, its always better if the information are together :wink:

1 Like

Ok. Also included ticket number in opening post. :wink:
BTW: ticket is recognised by core devs already, and core 149 isn’t available for i586 systems (as update ) anymore.
But what about the addons and the images for fresh install?

1 Like

I have rebuild the addons at the state of core148 and copied it to the servers but the mirrors need time to sync.

I also try to fix the problem but it seems difficult. gcc/binutils build i686 code with explicit -march=i586 at cflags.


Thx, Arne.
That means, we should switch to i686 with our systems as soon as possible.
I’ll test the addons this evening/night as announced in Bugzilla.

Better switch to x86_64 because i686 is also dying.
KPTI and other security fixes will not ported to 32bit in mainline kernel.

1 Like

Sorry, at the moment of posting I didn’t realize it is a problem 32bit in Linux. :frowning:

Thus, we should switch to x86_64 as soon as possible.

Michael Tremer wrote in Bugzilla:

Arne has found the issue in a new “hardening” feature in glibc developed by Intel. It is designed for modern processors, however did not check if it was compatible with i586 and therefore generated binary code which could not have been executed on those processors.

The core update will now be updated and can then be installed on i586 systems, too. We will not change the installation images.

I’ve tested this. No problems found, also with addons.
To be sure you get the new files you should delete files in /opt/pakfire/db/meta/ and /var/cache/pakfire/ , if you tried to install addons with the defective core149.

1 Like