Core Update 154

Core Update 154 applied and looking good so far.

I did do a reboot after the deed.

One issue for me.

I updated from 153 → 154 and fcrontab switched from nano editor back to the vim editor. And my fcrontab file changed and I lost the commands I had added in the past. (hopefully they are in the IPFire backup file).

Hi @jon

I am afraid they won’t be as standard. I have had the same problem in the past when I did a re-install on my system and found that one of my servers no longer came on automatically in the morning because of the change to the fcrontab file. I had to recreate everything from memory.

I also had nano set up as the editor in fcron.conf so I added /etc/fcron.conf into

/var/ipfire/backup/include.user

Any files/directories listed in here are backed up as well as the standard system ones defined in the include file.

The fcrontab itself could be backed up as well but that could be dangerous. Any new functions to IPFire could add new actions into the fcrontab when an upgrade is done. Those would be lost when you would do a restore as you replace the whole frcontab.

I created a script that makes a backup of my frcrontab once a month. When I do a re-install or there is an upgrade with a change I do not import this backup into fcrontab as you then again overwrite what is there. I just copy my additional lines from my local frcontab backup file into the latest system fcrontab. My local fcrontab backup files are included in my include.user file and also including all my scripts.

I am looking at the possibility to create an additional user in IPFire that can then have its own fcrontab created. That user fcrontab could then be included in the include.user file so that it is backed up each time. That would then work over upgrades or re-installs without putting at risk changes/additions to the system fcrontab entries.
When I have got that working properly I will add the details into the wiki.

2 Likes

Hello everybody,

since the update to 154 the wifi no longer works on my IPFire.

hostadp can neither be started from the wui nor via the shell /etc/init.d/hostadp start or by reboot. No PID is assigned. Deinstallation and reinstallation via Pakfire did not help either.

Does somebody still have an idea?

Thanks and many greetings
Sören

1 Like

Hi sirke,
have had exactly the same problem and also no way to find a good way to troubleshoot this problem (no logs). Have downgraded hostapd which is not a good solution at all but i needed to bring WLAN for the first back to life.

Since it seems that it works for mostly people may we have a problem according to the WLAN cards ? Which one do you use ?

Best,

Erik

2 Likes

Two years ago was the first time I had made a change to the crontab file. And in two years this is the first time I’ve lost the fcrontab file. Live and learn!

I’ll have to read about this - something new to learn!

I have a fcrontab backup from mid-Feb so I am only missing two recently added lines.

Maybe fcrontab can be added to the backup but not restored. At least there would be a reference available in the backup file. Not sure if that is easily possible…

My solution:

As root, I created ~/miscmods/ as a placeholder for any system file modifications. I also created ~/backups/ to replicate any pre-existing system files I touch.

I created new files for my fcron (and other) mods:

/root/miscmods/etc/fcron.daily/unbound-stats
/root/miscmods/etc/fcron.daily/updatedb
/root/miscmods/etc/fcron.monthly/isobackup
/root/miscmods/etc/fcron.weekly/wklybkup
/root/miscmods/var/ipfire/backup/addons/includes/roothome

I have a script in ~/bin/ called “diffmiscmods”, which locates any files in the ~/miscmods/ tree, and compares them to the files that are actually in use:

#! /bin/sh

ModDir=~/miscmods

if cd ${ModDir} ; then
InFiles=( $(find . -type f | sort) )
for FileCount in $(seq 0 $((${#InFiles[@]} -1))) ; do
CurrentFile=echo ${InFiles[$FileCount]} | sed -s 's/\.\///'
echo “${ModDir}/${CurrentFile} "
echo " /${CurrentFile} :”
diff ${ModDir}/${CurrentFile} /${CurrentFile}
echo “”
done
else
echo “Can’t locate ${ModDir} - exiting”
exit 1
fi

I have a “psuedo-addon” that creates a backup of /root/ (and I save the result to my user machine):
/var/ipfire/backup/addons/includes/roothome

contents:

/root/
/var/ipfire/backup/addons/includes/roothome

If I have to recreate my IPFire machine, I can retrieve my modifications in /root/ and manually compare them to new or missing system files.

I hope this may help or inspire others.

1 Like

Same Wifi-issue for me. APU2C4 with WLE200NX Wifi-Adapter.

Zone Configuration shows two Wifi-Adapters, however I only have one:

When trying to change something for BLUE, I always get error message “A zone that is not in bridge mode can’t have more than one NIC assigned” upon saving (regardless whether I assigned one or two NICs, or if I try to change any of the other settings)

Can you please provide the pakfire command for downgrading hostapd?

Thanks and best regards,
Chris

My nanopi R1 is still at core 154 testing, but its Broadcom WiFi is certainly working there.

Since I upgraded from 153 to 154 I noticed that the “launch-ether-wake” command that used to live in /usr/local/bin/launch-ether-wake has been deprecated (or deleted) so now it doesn’t work using that command to wake up devices.

When trying to run a file that contained the MAC address for a device, the error that I get is:

./Test_WOL: line 23: /usr/local/bin/launch-ether-wake: No such file or directory

I found there’s an etherwake file that lives in /usr/sbin/ that you can use with the command:

etherwake -i [Network interface] [MAC address]
Example:
etherwake -i green0 00:00:00:00:00:00

So there’s still a way to do Wake-on-LAN, it’s just a bit different to what I used previously, but is now actually a lot more simple than my previous script!

Cheers.

Good morning,

there is no command for downgrading packages in IPFire available. I used an old package hostapd-2.9-52.ipfire.

My Ralink RT5572 - 802.11 a/b/g/n Wireless Adapter from a Prime machine does not work with the new hostapd.

Best,

Erik

hi erik,

the WLAN card is

Network controller [0280]: Ralink corp. RT2790 Wireless 802.11n 1T/2R PCIe [1814:0781]
Subsystem: Ralink corp. RT2790 Wireless 802.11n 1T/2R PCIe [1814:2790]
Kernel driver in use: rt2800pci
Kernel modules: rt2800pci

according to commitmessage of @ms on git.ipfire.org at 18.01.2021 hostapd was updated to development version. from 2.9 to 581dfcc - whatever that means.

how can I downgrade to 2.9 stable? pakfire is not able to do so, I think.

best,
Sören

So we both have a Ralink chipset, have searched a little over the diff → git.ipfire.org Git - ipfire-2.x.git/commitdiff and haven´t find something obvious but am also not really inside that topic.

So there is a little more information according to this problem, may we can go to Bugzilla with this ?

@wussel
can you may also post some informations according to your Wlan card ?

Best,

Erik

Hi,

please open a bug report for this in Bugzilla. For information on how to do this please read blog.ipfire.org - How to write a good bug report?. This should not happen.

Reason:
A lot of Core Developers read in this community somehow irregular (although there are some very busy readers like Peter Mueller). This has nothing to do with ignorance just with a lake of time. We cannot monitor a handful of platforms for important information and so important information like the one which you posted here gets somehow lost.

Therefore please post this information in a bug report, that it gets recognized.

Greetings Jonatan

3 Likes

Bug has been filed → 12585 – Update with core 154 stops hostapd on some hardware. .

Best,

UE

1 Like

Hi Erik,

as mentioned above, I run a WLE200NX Wifi-Adapter on an APU2C4 board.

Please also see the Zone Configuration screenshot of my post above, which is the only “faulty” behavior I could document (expect Wifi not working, of course). Maybe this is helpful to further analyze the issue?

I tried to add both my WiFi adapter information and the screenshot with the Zone Configuration problems to the bug you created, but somehow I can’t find an option to create a bugzilla-user.

Best,
Chris

Your password and email address from this forum will work to log in to the IPFire Bugzilla.

1 Like

My Wifi access point also stopped working with the 154 upgrade. I have a

Ralink Technology, Corp. RT2870/RT3070 Wireless Adapter

Downgrading hostapd from 581dfcc-54 to 2.9-52 fixed it.

Since pakfire doesn’t seem to support downgrading, this is what I did to do the downgrade:

cd /var/cache/pakfire
cp hostapd-581dfcc-54.ipfire hostapd-581dfcc-54.ipfire.backup
cp hostapd-2.9-52.ipfire hostapd-581dfcc-54.ipfire
pakfire install hostapd

It worked, but if someone knows a better way to downgrade ipfire pakfire packages, please let me know.

I had this issue also… (I cant share my video since core 152 on meetings)