Core Update 143 - DNS has gone intermittent

I use IpFire to manage all device IP addresses on my local networks. I have the DHCP server set up with fixed leases for all devices and the ‘hosts’ file set up with names for all my local devices. The system primarily uses Ubuntu Linux servers and Linux Mint desktops.

Until recently I’ve had no problems. I’ve recently updated to Core Update 143, now my local DNS lookup has become intermittent, sometimes it works, sometimes it fails to provide the DNS lookup and access to local devices fails. Any suggestions please, this is causing me a lot of grief at present ?

PaulM

Hi PaulM,
Ubuntu systemd-resolved issue:
I had the same problem yesterday after update to 143, but I think this is related to Ubuntu,
I solved my dns resolver by a little modification to all my Ubuntu 18.04, try check your Ubuntu syslog(google is your friend to find solutions),
Error in my logfile:

systemd-resolved[398]: Server returned error NXDOMAIN, mitigating potential DNS violation DVE-2018-0001, retrying transaction with reduced feature level UDP. <<
Solved by modify the resolver:

sudo ln -sf /run/systemd/resolve/resolv.conf /etc/resolv.conf

Best regards SAX

Many thanks, I found the same error in my syslog file. Applied the fix and will see what happens, so far no further problems.

Bug #1774632 on launchpad appears to describe this problem.

Regards
PaulM

Beware if you use a VPN and apply this patch, your DNS lookups will no longer automatically be directed through the VPN, they will go direct to the DNS server, bye-passing the VPN !! Use dnsleaktest.com, or similar to check.

PaulM