Core 174 - Backup.cgi oom


Tried to download a generated iso from the web ui and every time i get the following error and network isn’t available for a few minutes:

13:13:26 kernel: oom_reaper: reaped process 27888 (backup.cgi), now anon-rss:0kB, file-rss:0kB, s hmem-rss:0kB
13:13:24 kernel: Out of memory: Killed process 27888 (backup.cgi) total-vm:3751692kB, anon-rss:28 99560kB, file-rss:0kB, shmem-rss:0kB, UID:99 pgtables:7384kB oom_score_adj:0
13:13:24 kernel: oom-kill:constraint=CONSTRAINT_NONE,nodemask=(null),cpuset=/,mems_allowed=0,glob al_oom,task_memcg=/,task=backup.cgi,pid=27888,uid=99

No problems before the update 174.

Similar issue, backup is created ok, but I get a timeout when trying to download. It all worked well before the last update.

Hall @mlayland and @angrytux

I have tested this out on my Core Update 174 vm testbed system and confirm that I have the same result. The download ends up consuming 100% of the memory and the oom killer shuts down the backup.cgi code.
Have also confirmed that the iso file can be downloaded in CU173 on my vm testbed.

Could you raise a bug on this.

Your IPFire people email address and password will act as your login credentials for the IPFire Bugzilla.

In my production IPFire system I do backups including the log files and these backups are around 500MB to 650MB and trying to download those backups causes the same oom killer response.

Doing a download of a backup without logs - around 12MB, this worked without any problems.

In my vm testbed system I have backup files of varying size. Testing out downloading various sizes I have bracketed the size to 99MB causing a oom-killer event and 61MB coming up with the download location request.

1 Like

As no one has raised the bug after two weeks, I have now done so.