Core 139 - Sound Beep, connect / disconnect

After update from 138 to 139 i have on every connect / disconnect a Beep. From Beginning i never used that Beep feature. As connection i use PPPoE

Maybe a fast solution is to save the settings again but iam interested whats going wrong. It seems thats a Beep Bug :slight_smile:


Sorry. I have missed this cgi in the core139 updater. Please run
touch /var/ipfire/red/nobeeps
to disable the sounds manually.

I will readd this cgi to the next core update.


Thank You, also in the name of my family. Not all are satisfied with the new morning sound (morning/night reconnect) :grin:

Under IPCop (not IPfire !), activating this feature (“Beep when …”) allowed a small melody to be played during the startup, shutdown or restart stages, which was useful for monitoring the status of the firewall.

Under IPFire, this option is inoperative whether or not “Beep when …” is activated.

Note 1: The beep that was added in the last versions of IPfire (connection of the red network) has nothing to do with it.

Note 2: It is possible to find the original function by executing the following commands - thanks to @roberto (but not deactivatable by the subject of this post) :

ln -sf …/init.d/beep /etc/rc.d/rc0.d/K99beep
ln -sf …/init.d/beep /etc/rc.d/rc3.d/S99beep
ln -sf …/init.d/beep /etc/rc.d/rc6.d/K99beep

Hi Steph,

it was a little bit diffrent if i remember correct. Under Cop was 2 diffrent settings.

  • connect/disconnect
  • start/shutdown

So i guess you must do a feature request :wink: I can only speak for us (my family) we are happy, all is muted again :wink:

Hi @anon33261557,

oh well, I did not remember that there were 2 possibilities of sound notification in IPcop :wink:

For fun, I’m going to install an IPcop (old “up to date”) to check this…

Note : Glad IPFire doesn’t wake up your whole family :slight_smile:

It seems thats not needed. I cant believe it the old side is back. Iam to 100% sure the side was gone in the past.

Indeed, you are right ! 2 different settings ! :slight_smile: