Connection unstable after 2.23 core 138 update

After updating from core 136 to 138 our connection drops every few minutes and comes back up by it self a few seconds later. Yo can tell by browsing the web or downloading any files. I had QoS activated but even if I turn it off it keeps droping the connection.
Is there an easy way to downgrade back to core 136?
Has anyone had a similar problem after updating?
I am a beginner with ipfire so bare with me please. Let me know if you need any more info about our connection.

So this does not sound like it is the QoS then. Do you use any other features like the web proxy? Can you describe the problem more? Is it just slow web browsing or would a Skype call pause for a couple of seconds, too?

No and you should not consider that because you are missing out on important security fixes.

Thanks souch for you help.

I don’t have web proxy enabled neither on green or blue. When the connection drops even the web interface of IPfire slows down or does not respond. The skype call would also drop. When this happens, the traffic info in the right upper corner shows – (0 data) both in IN and OUT traffic, after a few secons it comes back again.

I had problems before when downloading big files would get interrupted and fail. I solved it just by enabling QoS.

It looks like something saturates the system.

I use the GREEN interface for the main LAN, BLUE for another LAN but rarely used and ORANGE for VOIP.

Can you see any high CPU usage in the graphs?

The Idle CPU Usage is at 99%the whole time. I don’t know if that is normal. Seems like it has been like that for ever. The rest of the values seem fine. Average below 1%
For the rest of the graphs I don’t see any changes since the update.

Average below 1%? That graph isn’t in percentage and it should be very close to zero if you CPU load is so low.

Anything when you run ‘dmesg’ on the console? It could be a hardware problem.

May you pls have a look into the system log? Choose “kernel” in the drop down menu, click the refresh button and search for “link up” and “link down”. If you get many results for your NIC that’s used for your GREEN network you or actually your switch looses the physically connection to your ipfire system.


The top graph (on x86_64 at least) displays CPU usage in %. The table below it is the complementary CPU Idle, also in %. Are you interpreting that correctly ?

If the average idle is below 1% then your IPFire box is way undersized. How many users and what Internet bit rate is it handling ?

This is the graph that I am refering to:

Im going to run dmesg in a bit and I’ll let you know what I see.

Im an getting a lot of these, like two times per minute:

08:49:54 kernel: e1000e: green0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
08:49:50 kernel: e1000e 0000:00:19.0 green0: Reset adapter unexpectedly
08:49:48 kernel: PCI Status <10>
08:49:48 kernel: PHY Extended Status <3000>
08:49:48 kernel: PHY 1000BASE-T Status <3800>
08:49:48 kernel: PHY Status <796d>
08:49:48 kernel: MAC Status <40080083>
08:49:48 kernel: next_to_watch.status <0>
08:49:48 kernel: jiffies <1003d6700>
08:49:48 kernel: next_to_watch <9c>
08:49:48 kernel: time_stamp <1003d60db>
08:49:48 kernel: buffer_info[next_to_clean]:
08:49:48 kernel: next_to_clean <99>
08:49:48 kernel: next_to_use
08:49:48 kernel: TDT
08:49:48 kernel: TDH <99>
08:49:48 kernel: e1000e 0000:00:19.0 green0: Detected Hardware Unit Hang:

There you got your problem. It’s hardware-related! e1000e isn’t that an Intel controller? I use Intel controllers as well (i350) and don’t have any troubles with the drivers. Do you use an addon card or onboard? Testwise replace the cable to your network switch and/or check the functionallity of that card within another operating system (if possible).

Edit: in case it’s addon it’s always an good idea the check for firmware/bios updates of your motherboard.

Green is connected to the onboard card. Red, Blue and Orange are addon cards. I could use another addon for green but I don’t think I have any more slots available. Green is the one with the heaviest load. Should I reconfigure and connect RED on the addon?
Thanks so much guys.

I don’t think that this will solve the problem because you will just put it to another network, except you will use another interface. If the problem really startet with the Update to build 138 I think it has something to do with kernel fixes regarding CPU vulnerability so in your case I would check for any BIOS updates first and as already mentioned take the system off its usual function and boot another operating system (for example any portable) to check the hardware.

If you lack on slots you should reconsider dual/quad network cards.

I have updated the BIOS and althought it seems a bit better, I still have problems and the green adaptor keeps reseting. The improvement could be because I am all alone now and no connected users. This firewall manages a LAN with at least 20 office users and a lot of other WIFI users.
Next thing to try is to test the motherboard on another OS and see if the onboard adaptor malfunctions right? Or should I just go and buy a new double/quad adaptor? Maybe it’s just too much traffic for the onboard adaptor and that’s why it fails?

I would just be interested in finding out if it’s an software/driver or hardware-related issue.
If NIC and driver work well no traffic should result in an hangover and reset. If you intend on bying a new network addon card I would suggest to buy a Intel i350-T4. They are cheap (got that 30$ chinese products) and work well for me since years.

I’ve been reading and it looks like there are some known issues with the e1000e driver and the intel onboard adapter. I think it is driver/software related. While I fix the problem or get a new card, can I just change in Zone Configuration the NIC assignment for green and use the blue one? The Blue interface is not being used right now. Can I just change it there and then switch the network cables and that would be it or would I break something?

I would convert my eth0 and set to native in GREEN. BLUE I would just set it to None. Then change the cable.

Ok. I solved it, at least partially. I am now using the NIC that was in BLUE with the GREEN interface. Working like a charm. I did it in console just to make sure. I am going to get that Intel i350-T4 anyway and leave the onboard card unused.

Thanks so much for all the help. I’ve learned a lot.

Our system was setup by someone that knew how to install it, but has no idea what to do when problems occur.

May you pls post the article where you’ve found the driver issue information? That’s totally new to me and about 5 years ago (I know it’s a long time ago) I was using onboard Intel NICs myself and haven’t had any problems.

It’s not an article. Someone comented about this on the old forum.

The motherboard on my ipfire system is an ASUS H81M-P PLUS

I am almost certain that If I try this motherboard with Windows OS for example I would not have any problems. I might try it some time just for peace of mind.

1 Like

First I thought: hey you’ve got that board twice, but I have the Asus H81M-K

So if you add that in /etc/sysconfig/rc.local you should be fine. Just give it a try:

ethtool -K green0 gso off gro off tso off sg off