"Connection refused by proxy server" problem after update to CU 177

bye and have a good day
I have a strange problem after upgrading to the latest version (177)
my IPFire is configured so that all traffic goes through the proxy, so I created the rules so that each client is automatically configured the proxy
until before the update everything worked perfectly once updated it doesn’t allow me to browse and always gives me the error “Connection refused by proxy server”
but if i disable the proxy everything works
ps I had enabled clamav

ClamAV plugin for Squid has been removed. I wonder if something has gone wrong after the removal. Is your Squid running?

1 Like

that it was removed I know and that’s why I indicated it
you’re right the proxy is stopped but I don’t understand why ?
what can I do

solved I found what was blocking it, saved it and restarted
Thank you

1 Like

What was it?

it required to save the configuration and restart it



FYI, in my case saving the web proxy configuration and restarting it was not enough on several IPFire :

Before saving, I also had to modify something in the page (check / uncheck a box, change a value…)

I’ve just looked through the sources.
A ‘save and restart’ should write a valid config and restart squid.
It doesn’t depend on changes.

What I didn’t check yet is the processing of the clamav settings.
The steps are included in the source, yet. But the enabling should switch to ‘off’, to inhibit the trial to start a not existing program.

1 Like

I have the same issue with “connection refused by proxy”.
Clearing the cache and “save and restart” helped at first sight.
Now I have the same issue again with n-tv and even Wikipedia.

If I check out the box “Deny access to destinations hosted on fast flux setups:” in the proxy settings everything works fine.
Before updating to Core Update 177 I had never seen this effect.


@ip-mfg I had the same issue too.
By checking out " deny access to destination fast flux" i too have a working system.
Stranger is that, i am on cu 176 with nothing changed since yesterday.
Since my problem started this morning without any change to my set-up, i believe that some sites change their set-up.

Thank’s for your hint !

(edit) I had to untick “Deny access to destinations hosted on selectively announced networks:” to fix the remaining sites not working to working state.


Added just for completeness about
“Deny access to destinations hosted on selectively announced networks:


Thank’s too for the hint.
I untik the the boxes for “selectively announced networks” and for “fast flux”.

Is a quick and dirty solution, but it works.

1 Like

maybe doesnt belong in here: but with update 177, on several installations, I was unable to get Microsoft Windows Updates. Yesterday I was really confused, today I saw this thread. Also, I was not able to install Citrix Workspace App. After restarting Squid and cleared cache, everything was working normal again and I was able to install everything.

So thank you for your input.


After saving and restarting Squid, I had problems going to certain websites, including amazon. I got a layout completely screwed up. After clearing the cache the problem went away.