Concurrent max_user_ip

Hi, I’d like to limit concurrent user login to 1
To avoid user snooping username and password, and enter credentials on another workstation after small time inactivity I set long time ttl.

But I can’t save this configuration.

Error messages
Authentication cache TTL may not be 0 when using IP address limits

What I did wrong?

Its maybe much to high? Default is 60 min but you try 1 week. Maybe its interpreted as 0.

Also I’ve tried with small values, such as 1, 10 etc… same result
I using last available stable release for today.

Sorry i can not really help with this it was only a suggestion because the setting was so high.

I had never used this feature before so i played a while with it also of course with the new core 142. All i can say i have the same thing like you no matter what i try. After i limit the IP it plays no mater what TTL i use. Always the same error.

I also did a quick test on fresh install old core 138. It was the same. Maybe a bug. Must a expert answer

If you set the TTL to zero, that would mean that squid never caches the credentials and will always go back to your authentication backend.

In your case it is local, so it is irrelevant. However, authentication should be checked with every request.

Michael, please, take a look at screenshot. There’s no zero value.
How to save config?

1 Like

Oh, I didn’t get it from your first post.

This is a known issue which nobody has fixed, yet:

1 Like

Also I tried :

  1. save values to conf file
  2. refresh proxy config page
  3. click save and restart
    Same result.

This ticket has no ETA.

Will it work properly if I configure external radius server?

I do not know that.