Clicking upgrade button on Pakfire does nothing # Resolved#

Hi All,
when I click on the upgrade button in nothing happens. Is there any command i can run instead.

Log on to your console via ssh and type pakfire upgrade
pakfire has various options (install remove update upgrade list status)

Giving me the below error

Try, pakfire update … does it bring server-list.db and packages_list.db ?
Can you ping outside (eg. ping

My output:

[root@ipfire ~]# pakfire update
server-list.db       100.00% |=============================>|    2.22 KB
packages_list.db     100.00% |=============================>|    4.72 KB
[root@ipfire ~]# pakfire status
Core-Update 2.25-x86_64
Release: 144 -> 145

Core-Version: 2.25-x86_64
Core-Update-Level: 144
Last update: 48d 21h 59m 19s ago
Last core-list update: 6m 38s ago
Last server-list update: 7s ago
Last packages-list update: 6s ago
Core-Update available: yes (145)
Package-Updates available: 0
Reboot required: no
[root@ipfire ~]#

getting the same error.

[root@ipfire ~]# pakfire status

Giving up: There was no chance to get the file “lists/core-list.db” from any ava ilable server.
There was an error on the way. Please fix it.
Core-Update 2.25-x86_64
Release: 144 -> 145

Update: cups
Version: 2.2.2 -> 2.2.2
Release: 19 -> 20

Update: libtiff
Version: 4.0.6 -> 4.1.0
Release: 3 -> 4

Update: cups-filters
Version: 1.13.4 -> 1.13.4
Release: 2 -> 3

Update: clamav
Version: 0.102.2 -> 0.102.3
Release: 49 -> 51

Update: ghostscript
Version: 9.26 -> 9.26
Release: 4 -> 5

Update: wio
Version: 1.3.2 -> 1.3.2
Release: 7 -> 8

Core-Version: 2.25-x86_64
Core-Update-Level: 144
Last update: 27d 6h 10m 47s ago
Last core-list update: 6d 14h 47m 52s ago
Last server-list update: 6d 14h 48m 13s ago
Last packages-list update: 6d 14h 48m 11s ago
Core-Update available: yes (145)
Package-Updates available: 6
Reboot required: no

What DNS are you using?

[root@ipfire ~]# ping
PING ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=55 time=162 ms
64 bytes from ( icmp_seq=2 ttl=55 time=157 ms
64 bytes from ( icmp_seq=3 ttl=55 time=160 ms


I suggest you reboot and fix DNS so the Status: says, Working instead of Broken.
Then, you should be able to ping by name and update/upgrade.

I restarted the system but that did not solve the issue. Do you suggest me to manually reinstall the whole OS and restore the configuration from backup.

Could you please help me to fix the DNS issue , if its a simpler problem.

Set your DNS configuration to UDP, Standard, define and as your DNS entries.
click “Check DNS Servers” button. If that does not say, Working, restore config from backup.

Added new DNS entry of Google, getting the same error.
IPfire is not able to communicate with DNS server, rest of the systems in the network are able to connect.
I even added in /etc/hosts , still the same error.

I think unbound is having a fit …
/etc/init.d/unbound restart
do you get errors?

yes , getting error

is unbound running now?

netstat -tlp

tcp        0      0 localhost:8953          *:*                     LISTEN      8218/unbound        
tcp        0      0 *:domain                *:*                     LISTEN      8218/unbound

I did base on another suggestion in forum
rm /var/lib/unbound/root.key
unbound-anchor -a /var/lib/unbound/root.key
/etc/init.d/unbound restart
Now ipfire able to resolve Running the upgrade from GUI.

thank you very much Paul for all the help extended. I appreciate your time.

you’re welcome.