Cheat sheet to get a console install with a minimalistic text mode?

Hello there!

Haha, funny that it is another visually impaired that is at the origin of this post!
As it happens, I am blind as well.
My issue is likely similar. I run the installer over IPXE, and very quickly at boot, the console shifts into gibberish, although it may be some ASCII art or something along those lines. A lot of odd symbols, but many underscores and such.
Anyway, there is a message, the only line I can read, which says I have 3 seconds or less to either press a key, or I can just wait. Using the arrow keys possibly stops the countdown, but the message disappears and it is the only legible content. I cannot decipher which option to pick for a console install.

Do you have any suggestions or cheat sheet to get a console install with a minimalistic text mode? (i.e. press c, or arrow down twice and enter, etc)I’m connected via serial port.


Haven’t read this old thread again, I suppose main problem is the serial connection.
This ‘old’ type of computer access is very simple. Just some wires ( minimal 3 ) and two communication partners which use the same protocol ( language in normal life :wink: ).
But, there is no adaption to errors. The signal on the line is just sampled and interpreted by the receiver according to the parameters

  • baudrate, the frequency of the signal
  • character length, number of bits
  • optional parity bit for error detection, usually not used ( None )
  • number of stop bits,marking the char end

Setting these parameters to wrong values results in misinterpretation.

IPFire uses 11500Baud, 8N1.
There were problems in the boot process, but nowadays these should be solved.

At which point exactly occur the false characters?
The IPXE process run in the BIOS of the board. After loading the OS from remote, this ( IPFire with grub bootloader ) is started.
Which HW do you use?

this should help:

EDIT: forgot to add an important part:

Hello @dd0ke - Welcome to the IPFire community!

You are marvelous!
Using the cheat sheet for APU, I was able to boot the installation. I had to try a few times, not knowing still if my interrupt key counts as 1x down-arrow or not, etc.

For the 11500bauds, I did try, and it didn’t help.

I’m using an APU4, can’t remember the model exactly.

Thanks for such a cool community!

1 Like