Can't upgrade to 166

I’ve tried doing this using the UI and command line but the result is the same (here are the command line logs):

[root@ipfire2 ~]# pakfire status
Core-Update 2.27-x86_64
Release: 164 -> 166

Update: wio
Version: 1.3.2 -> 1.3.2
Release: 13 -> 14

Update: speedtest-cli
Version: 2.1.3 -> 2.1.3
Release: 4 -> 5

Core-Version: 2.27-x86_64
Core-Update-Level: 164
Last update: 25d 18h 26m 25s ago
Last core-list update: 21m 31s ago
Last server-list update: 21m 36s ago
Last packages-list update: 21m 33s ago
Core-Update available: yes (166)
Package-Updates available: 2
Reboot required: no
[root@ipfire2 ~]# pakfire upgrade
CORE UPGR: Upgrading from release 164 to 166

Giving up: There was no chance to get the file "meta/meta-core-upgrade-165" from any available server.
There was an error on the way. Please fix it.
No filename given in meta-file.

The box definitely has Internet access (I’m connecting to it using an internal OpenVPN connection) so it’s possible that the update location DB is not in a good state.

I’d appreciate pointers on how to fix this.


Without the concrete messages from pakfire in /var/log/messages it is not easy to give some advice.

Thank you for the pointer - for some reason the DNS servers were not reachable (or Unbound was in some bad state).

Restarting the unbound daemon by itself didn’t fix it but adding a new DNS server (Cloudflare’s fixed it for a while and I was able to do the upgrade.

I’ll need to figure out why the DNS resolution was broken but this is not an upgrade issue

1 Like


to do so, looking at the logs of Unbound, IPFire’s DNS resolver, might help. For example, by running this command on your IPFire machine:

grep unbound /var/log/messages

Thanks, and best regards,
Peter Müller

Sorry, have been traveling so not much time to follow-up here.

When I looked at the logs it seemed like one of the IDS rules (Talos VRT) was being triggered by the DNS over TLS lookups and was causing Unbound to be unable to get most hosts resolved after the suricata daemon was up.

After updating both IPFire and the rules everything has worked OK for the past week or so.

1 Like