Can't update Win11 or Linux

For some reason I can go out on the internet and do almost anything except update my Win11 or Linux. In order to update I must use a VPN to get connection. Without using VPN all my repositories respond with “connection refused”. I can bypass IPFire and everything works as it should. No issues. I’m sure the updating issue in IPFire is due to some setting I have made. I have tried changing many things in IPFire and ended up having to do a reinstall. I can’t find anything on the internet or in your wiki that is related. I have decided that this issue is one that can only be resolved by a professional. I am learning but am FAR from being a professional. Most likely the issue will be simple and obvious to a professional. If there is any online info about this and how to fix it please just post the URL for me.
As far as posting logs go, I can’t find any error logs in IPFire that show any info about this issue. My apologies for not having the knowledge of isolating the correct logs to post here. Any help in this matter would be greatly appreciated.

As a guess: Do you have IPS enabled?

If yes, then you may want to turn it off while you debug this. This is what I ran into in the past. It is related to installed with apt. It won’t help with Win11.

1 Like

Thank you very much for your guidance. I did have IPS enabled but after disabling it I still had an issue. Through much trial and error I finally located the program causing my issues. It was having the proxy enabled. I’m not sure WHAT was the exact cause in the proxy settings but that was the offender. I now have IPS enabled and all other desired attributes enabled…except for proxy. Now my apt update works fine. Now I will check on the Win11 and make sure it updates as it should. If not then most likely it is a different issue causing it.
Again, thank you so much. If not for your post I would not have had any ideas about where to look or how to test.

1 Like

Hi,

on IPFire or your clients?

Updating Linux and Windows (10) systems behind a proxy works for me. Linux is usually quite proxy-friendly, while Windows is pretty picky when it comes to proxies - especially if proxy authentication is enabled.

If there is a general issue on that front, please let us know. We’re here to help. :slight_smile:

Thanks, and best regards,
Peter Müller

Hi,

Full Ack! :wink:

JM2C :wink:

I don’t have any Win 11 machine running yet - but I would check the following:

The first step is always to enter the proxy settings in the “internet options” of the control panel.

But:

Source: How the Windows Update client determines which proxy server to use to connect to the Windows Update website

So afterwards, open an elevated prompt (cmd-console) and check the following:

netsh winhttp show proxy

This should give you something like


Aktuelle WinHTTP-Proxyeinstellungen:

    Proxyserver     :  [PROXY_IP:PORT]

If proxy is missing here got to next step:

Import proxy settings:

netsh winhttp import proxy source=ie

Or set proxy manually:

netsh winhttp set proxy proxy-server="PROXY_IP:PORT"

HTH,
Matthias

Hi,

regarding linux (for me: Ubuntu 20.04.4 LTS):

You might need to edit /etc/apt/apt.conf:

Acquire::http::Proxy "http://PROXY_IP:PORT/";
Acquire::https::Proxy "https://PROXY_IP:PORT/";
Acquire::ftp::proxy "ftp://PROXY_IP:PORT/";

Best,
Matthias

1 Like

Wow. I thank you all for your suggestions. Right now proxy is disabled in IPFire. I had no doubt that my client settings were wrong. Your replies are right to the point. I will investigate and see if I can make it work. Right now I just use VPN for most of my online connections. I do appreciate all your responses.