Can't figure out how to install to MSATA

Hi all, this is driving me nuts:
my running IPFire broke after update, so I decided to get a new APU6 and set up a new firewall, to use the other one as a backup. Take note: I have gotten IPFire installed on an MSATA card inserted in the APU before…

I can’t figure out how to do it now!

I’ve got it all set up, it boots from SDCard. The interfaces are configured and I can load the GUI on a laptop connected by ethernet.

The MSATA card is correctly identified as sda and it sees the right manufacturer and size.

But I can’t figure out how to get the installation / configuration onto the MSATA…

Please help? Its probably a totally stupid oversight, but I’ve been at it for 3 hours and can’t see the trees for the forest…

Thank you.

This should be a normal installation process:

  • write the IPFire .iso to the SDCard
  • boot from that card and do the initial setup ( with serial connection! )
  • on reboot change the boot order in the APU BIOS; first device should be the MSATA holding the configured OS

Now the system should only need the MSATA. You can remove your installation media.

1 Like

Hi Bernhard,

I would agree, that makes sense.
Unfortunately, it doesn’t work. When I select the MSATA to boot from, I get an error that there isn’t a bootable partition…

Very odd

Quite honestly, looking at these instructions:

This did NOT pop up. Neither did the language selection. I’m wondering if there is something wrong with the 167 installer?

BR Nick

I don’t think there is a problem with the installer. I do not remember any issues since release of this CU.

What messages do you get on the serial console?
How did you write the ISO to your SD card?

This should work.
On the USB stick you burned the iso… not the img. file correct?


what size is the MSATA disk?
I ask you this because I too have had difficulty installing a C167 on a J1900 again.
My drive was 64GB, I tried to replace it, believing it to be bad, with a 32GB one and everything worked.
But the funny thing is that on the allegedly broken disk I then installed Ubuntu Server, which runs on an APU4, and I didn’t have any problems.
Since I am also in an emergency situation, having to replace a firewall that had failed, I have not investigated further, but if you have a smaller disk available, try.


1 Like

If you boot from an SD it will be identified as /dev/sd(x).

You have to install to a different /dev/sd(y) - your mSATA. I suspect that you have installed over the SD.

1 Like

Hey everyone - thank you kindly for your help. It turns out I’m too big a noob for my own good.
I had downloaded the IMG instead of the ISO. So the system just ran from the SD Card.
Perhaps it makes sense - to accommodate people like myself ( :grinning:) to add, in parenthesis, what each download is for? Would have saved me about 3h of useless toil.

BR Nick

Thank you @hvacguy for the helpful hint :slight_smile:

I think this chapter of the wiki describes it enough.

1 Like

Plus there are more techniques possible. I simply xzcat the IMG.xz file directly to the mSATA. This is described in the wiki under ARM, but works just as well for x86_64. I anticipate that if someone tried that with the ISO file then they would get an error message.

For mSATA, it does require removing the mSATA or booting a utility Linux.


This is possibility, to extract the image file. But the disk images contain an ‘all purpose installation’. The way with the ISO installs the system according to HW.
The SDCard or the USB device hold the OS for installation of IPFire to the main disk, the mSATA.