Can't do an install with core 174

When I tried to install core 174, it kept hanging up trying to download the core. I got an error “” (may have misspelled that. I wrote it down) The console showed a 404 error.

I installed core 173 and updated to 174 without problems. Core 173 didn’t seem to do a download. Is this a change for 174?

Firstly, the download is hanging because the installer still has the old URL definition for the download site which was changed a while ago. A bug has been raised on this and the URL in the installer has been patched in the next branch of the repo which will be in CU175.

Secondly, normally the installer should install everything from the iso that you downloaded. If the installer is trying to download it from the IPFire download site this is an indication that the iso is likely corrupted. It shouldn’t happen with any CU iso file.

When you downloaded the iso did you confirm its sha256 hash that is provided on the download site. This is always worth doing to ensure that the download went without a hitch. I have not had it often but it has happened that the sha256 hash of the downloaded file was different and on re-downloading it was then correct.


I just did a recheck on the sha256 hash and it reported OK

I am presuming that you have the iso on a usb stick. How did you copy it on to the stick. I have never gad a problem with dd but some people have reported problems with Balena Etcher or Rufus. Maybe redo the copy to the usb stick.

Attempting to download from the url is a sure sign that there is a problem with accessing the code in the iso.

1 Like

I did use Balena Etcher.

I can’t help you with Balena Etcher. I have always used dd for getting IPFire and Arch Linux onto a usb stick.

Others on the forum do have experience with it so wl be better placed to provide suggestions and help.

I’ve used Balena Etcher to install many different systems and this is the first time I had a problem.

I did put core 173 on a usb stick with Balena Etcher and it installed. Then I upgraded it to 174. So I’m good.

I just thought I should mention it so that if anyone else had the same problem or if there was a problem with the image.

I do suggest that the installation should check the image and give a more meaningful error message than just listing the URL.


I saw that you got things going OK. :+1:

Today is a cold and rainy day and I figured I’d give it a try anyway…

  1. I download the iso from: just to make sure it downloaded. All seemed OK. (no hash was tested)

  2. I downloaded the newer version of Balena Etcher (v 1.18.4) and it installed it on a Mac.

  3. Since Etcher has the ability to Flash from URL I picked that (I was not sure what you had picked). And then I entered the above URL into Etcher.

  4. I picked an old 64 GB thumb drive as the target. And clicked Flash.

Everything seem to “flash” A-OK.

  1. I unplugged the thumb drive from my Mac and plugged it into into a new “box”.

  2. All booted and setup started as expected. Installed complete A-OK.

So things seem to work for me. Do you remember any errors beside the “404 error”?

EDIT: I am one of the people that had trouble with Etcher using ISO images in the past. So I switched from Etcher to dd.

Etcher has always worked A-OK for “Flash Images” like those that end with img.xz.