Cannot "unblock" Virtual Machine

Hey everyone,

I have a tiny problem, I guess it’s just something that I’m overlooking but I cannot seem to find the solution.

My laptop runs on linux but from time to time I need to use some Windows-tools. So to make it easy, I run a Windows-VM inside VMWare Workstaiton Player (the free version), which works pretty good.

The network-configuration is


so the VM has it’s own IP-address.

In the WUI of IPFire everything regarding the VM is shown correctly, the IP-adress is correct, the MAC-adress is correct, that it’s in the BLUE-network is correct (because the laptop itself is connected via WLAN), etc. I also activated AccessOnBlue for the VM.

But whatever I configure, IPFire blocks the traffic coming from the VM, more precisely it blocks the DNS requests the VM is sending to the IPFire-address on BLUE (because it’s the DNS-Server). IPFire also blocks the packets from the VM to the broadcast (in the same network). I even tried to change the DNS for the VM (changed from to but then IPFire blocks the forwarding.

I tried applying rules for the whole BLUE-network and for just the IP-address of the VM, I even changed the standard-configuration of the firewall, so that IPFire does not block forwarding pakets, but still everything from the VM is blocked.

Does anyone know why?

Blue access requires two things, a Mac address identifier and an IP address. Can you check that you have a separate MAC address for the VM and that the IP address shown in that table is also the address that the VM gets from IPFire DHCP?

Once I changed the DHCP allocation range, and I forgot to update that table. It took me several days of staring at the logs before I finally activated my brain cells and corrected the IP address in Blue Access.

Hey cfusco,

thanks for your reply! I checked again and everything seems to be correct. This is what ipconfig in the VM tells me ( is the IPFire’s address in BLUE).

Bildschirmfoto vom 2023-03-27 20-41-34

That’s the entry from IPFire-DHCP-Server.

Bildschirmfoto vom 2023-03-27 20-42-07

And this one is from the AccessOnBlue-menu.

And the IP-address and MAC-address are definitely different from the ones of the host.

After all the firewall is “recognizing” the VM correctly, because it successfully blocks all the DNS-requests as I can see it in the logs… still don’t know why.