Cannot reach WUI, but I have internet

Thanks for reading.

I installed/flashed IPFire 2.27 on RaspBerry PI 3b. I followed the installation setup ( - Step 6: What's next?) .
Green is on, dhcp for 3.10 - 3.35
Red is on 192.168.1.X range dhcp

ISP → Router ( - > IPFire ( → Home PC (received dhcp, DNS on 3.1 and 1.1)

PC can reach internet, but cannot reach WUI. Normally, cannot reach the router on - I need to access this through an open IP 84.XXX.XX.XXX

on IPfire, when using ipconfig -a (I see the green and red networks accordingly)

Tracert / ping PC → IPFire / Router DNS - > results in general error, or no trace at all.

I tried reinstalling IPFire from scratch, but since I have an internet connection via IPfire, via the router, And my router also still provides e.g. WIFI to mobile devices, I cannot grasp why I cannot reach the WUI at all, not on / localdomain. . :444, 3.10:44, 1.1:444 - Am I Missing something here?

Welcome to the IPFire community.

Do you have the following page read?


The installation routine has a last step, for Networking, which is to enable DHCP (which is not enabled by default). Did you do that step ?

Are you using the onboard NIC on RPi3 as Green or Red ?

1 Like


Yes, I did :slight_smile:

Yes, I think you mean the Green DHCP network config, where I configure what the lease on the green network is? As described, I have that on the till

I am using the onboard LAN for the connection from the Router - > RaspBerry (IPFire). And a USB to ether adapter to connect the IPFire - > My PC. As mentioned, I can access the internet through this configuration.

I was referring more to the previous step 5 enable DHCP. If that is not done, then the WUI settings for DHCP might be ineffective. To my knowledge, a reinstall would be required to enable DHCP, if that setp has been missed.

Using the onboard NIC for RED0, as you are doing, is generally more reliable.

1 Like

Hey @rodneyp I can confirm that I followed each step in step (5).

USB NIC, as you are using for GREEN0, can be problematic. Try unplug/replug it. If that still fails, run “lsusb” to see whether or not it is found by the operating system.


I agree. I always use the built in ethernet for green. And the USB ethernet adapter for red.

EDIT: Like this:

I have the opposite philosophy:

  • if RED0 is onboard, then usually it will work, IPF will complete the boot process and, with keyboard & monitor upgrades or options can be installed
  • with USB GREEN0, adaptors can be replugged or swapped until something works

Hi all,

thanks for the responses.

for clarification; with the current setup my internet is working trough IPFire. I just cannot access the Web User Interface - even when receiving an IP Address from IPFire Green DHCP via ethernet.

I will swap them to see how that works out :slight_smile: I will let you guys know in some hours from now.


Odd! You have access to the gateway trough external IP and can’t access webgui. Disable Intrusion PS, might you have enabled it!? Actually that access (Public IP) is for ISP’s workers&security researchers1 :D, wich I recomend disabling might some malware or MINT as DDos abuse it. That gateway is yours and not for general ISP’s public uses. Eventhough seems you aren’t using bridge mode in ISP’s router/modem. Do the test without suricata enabled then turn it on again after test. If you have access to console you can disable on nano /etc/suricata/settings2 off for the options. restart network /etc/init.d/./network restart. Personally I recomend setting up you ISP /router/modem with cable off and close access to it ifrom outside if possible, might your gateway be on the end side of ISP*3 rather then acctually your phisical modem!!! Let us know if it work fine!
Edited. appologies just woke up
*1 Some ISP’s alow router configs trhough web apps - it’s from this side the app get acess to it.
*2 nano /var/ipfire/suricata/settings
*3 This is a major problem unless you trust everybody that works at the Internet provider :see_no_evil:

Appologies suricata settings are on var. nano /var/ipfire/suricata/settings

O my goonss… especially (3) worries me. I have nothing of worth here, but still some privacy is great. I like to see what’s coming through the front door ^^

Meanwhile, I am receiving error on booting, although internet connection precedes. I am reinstalling IPFire once again. I think it is time for a new SD card…

  1. I think this applies here - I am on the telephone with my ISP right now, hopefully they can clarify this. They probably ask me if I already restarted my router xD.
    edit: as expected, put me on hold, hang on the phone. they do not support these kind of questions, GG. I will call again later.
  2. Let me look for this once I have it installed, will be back!
  3. Oeps. Auw, PS, this is not open invitation :smiley:
    edit: do you mean that I should hard reset the router, do not make a connection via ISP, setup IPFire, and than connect through ISP?

You may have forgotten https:// at the beginning of the address :wink:



1 Like

Worrie not, you’ll need a dedicated stalker with IT knowledge and ISP connections to get to that point. Unless you are a detective agencie or operate a secret infrastructure. ISP’s responsability is to provide internet. your personal firewall and apliances is not their responsabilitty as well. As long as your protected on your side, attempts to attack or offend will decrease as there are other easy potential targets, I supose! I believe that’s suricata blocking your access to the router, either you can double refresh the browser on the blocking page and see if the login cerdentials come up. Whitelisteing your private IP on IPS (down page will help - only the PC or device IP, and have AntiVirus on them) is an option too or disable one of the zones where Intrusion PS execute. PS right- https is important to remember too as tphz expressed,. as long your logging on localdomain worrie not about ssl certificates at the moment (chain locker)

Ok I’ll try to be as short as possible without neglecting people’s time here.

@tphz thanks for pointing it out, but yes I tried - also my browser is enforcing this anyhow at first attempt.
@g70p (2) : That is a release. As far as I know, nobody hates me this much. I understand the responsibility part of my ISP. Figures why they did not call me back.

Reinstalled IPFire to ensure green/red NIC are according to the documentation. I am back on the internet again! Just to clarify, in the image in the docu, it states a switch between IP → PC. My PC is directly connected to IPFire, could this cause any issues?

@g70p : I ended up in a blank document/screen with some ^options (read 0 lines). There seems to be no data in this doc: nano /var/ipfire/suricata/settings. I tried googling how to turn this off, but I am not really getting anywhere. Except it seems this is some kind of build-in prevention system. Are you referring to IPFire as the router?

Furthermore, is there any use of IPFire in this scenario where I cannot access the webUI, but my PC is apparently connected through IPFire through my router → internet?

No router - ips on ipfire! but ok if it’s blank it’s not turned on.!.If you have access to the console from root type elinks you have to have access to the inbuilt browser (use the keyboard to navigate-not easy TAB to move space to select ESC for menu) see if reachable. other way can’t help further.

If you can access webgui on ipfire machine trought the console, it may happen you have some security option in your PC blocking access. try other browsers or change some AV options?! Some extensions like HTTPS everywhere block webguis accesses


thanks again for the response!

I was able to reach this, once there and after logging in as admin user, I received an “500 internal server error or misconfiguration and was unable to complete your request.”

Ok all, thanks for helping out and using your time. I eventually looked into a different direction. I tried reentering my normal LAN - and tried to access the routers address using my mobile phone. This worked on the Apparantly My NordVPN has an option ‘stay invisible on LAN’ which kept me from accessing any device on the network… I already threw away my attempt on reaching and tried with OpenWRT. I am switching back to IPFire and will let you guys know how it worked out!