Cannot access openVPN from outside network


I’ve tried to search the forums but I couldn’t find anyone with a similar question so I hope I can post a new post.

My current configuration ISP (24.*) ---- Red (146…)---- ipfire ---- Green ( ----- Router ( ---- Desktop (

I set up openVPN server and client and everything connected over the same local network. However, when I try to connect openVPN with my outside network I noticed that openVPN cannot connect. I’ve tried to change firewall rule to forward my traffic from RED to OpenVPN and vice versa but no luck.

I noticed that when openVPN successfully connected on my local network it said that my server public IP is which is my LAN IP address. SO I tried to change the LOcal ip address in the openVPN local ip address setting but that doesn’t seems to work either.

I am not sure where I have gone wrong.

Thank you for your time.

on the global settings page there is an input field named ‚local vpn hostname/IP’. The explanation on the wiki is correct however the naming is somewhat misleading. This needs to be the ip of the red interface NOT your LAN interface (e.g. green). Have you checked that? I recommend the wiki page for OpenVPN which explains everything pretty well.


Thank you for your reply.

I did followed the wiki page and successfully connected to the VPN but I’m not sure what is blocking my RED interface that if I try to connect to it from the outside network I cannot connect to my VPN server (ipfire).

I’ll try your suggestion to change to the RED ip address.

Thank you for your time.


So I did tried to change the local vpn hostname/IP to my public IP address but that wouldn’t even tried to connect even if I’m in the same network. I’ve tried to port forward it from my ISP router but I got no luck.

Thank you for your time.


Thank you so much for your suggestion. It worked.

I’ve changed the local vpn hostname/IP to my RED ip address I got from my ISP modem. Then configured forward port of the VPN set in ipfire with the RED ip address and everything worked perfectly.

May I ask if it is using the RED ip address then why did the guide/photo showed using the LAN ip address?

I’ve tried to look over the wiki but I may have missed it.

Thank you again for your help.

1 Like

Great, that you got it working. However I can‘t say why the guide showed a LAN ip address. I haven‘t written it.
Enjoy your vpn!