Cache Manager Menu For Web Proxy Not Loading

When I click on this link in the IpFire GUI

2020-04-22 15_25_22-Window

This page loads with no menu. URL is point at TCP 444 by the looks of it. It only displays the text:
Cache Manager menu for 172.25.30.1:

I had previously figured out how to fix this, but I can’t find the link I had referenced with the information to do it. I would actually like to see the cache manager menu lol. Can anyone point out what I am missing please?

If there is any logs or anything I should look for please let me know.

Thx

Whenever I click on Cache Manager Interface within the Cache Manager Menu I get this: InternalError: Missing Template MGR_INDEX

However never had problem with accessing the menu. I click on it, get a new login site for the manager, login with admin and that’s it.

My thing is that it loads https://IP:444 with the notes. It does give me a login screen but once past that… just the notes but no menu. Doesn’t giv3 an error either. New install of software at latest release.

Are you sure you have any harddrive or RAM space assigned to it?

Also squid needs to run -> webproxy must be activated for green and/or blue.

??? Screenshot pls.

let me know if I didn’t get the right screenshots or let me know what you need. I can always drop to cli and pull services directly

Yep this looks like the cachemanager is not active. Please post the parameters for the cachemanager (screenshot) here.

I figured it out. I was on a different subnet accessing the cachemanager site. I had to add the exclusion x.x.x.x/24

I’d like to jump into the conversation. Unable to logon to Cache Management, getting Unable to connect Firefox can’t establish a connection to the server at 0.0.0.0.

Using an infire mini appliance the configuration is:

Kenneth,

Hard to make out what your saying above. Are you saying you figured out the solution to the issue, OR are you saying you have a similar problem?

Thx

Eric,
I’ve a similar problem.

Hiya Kenneth,

What you most likely have a problem with is not your browser. You could use any browser and run into the same problem. This is a Sourcing IP or Network issue in the Squid Proxy itself. You will never be able to get to that menu without making a modification/exclusion/allow. Of Course… Its not documented anywhere in IPFire docs, so unless one was to figure it out, you wouldn’t know off the cuff. Ultimately what you would be doing is adding an “Allow” for your computer or network segment to get to that Squid Proxy Management Menu so you can use its functions. Hope this helps…

You have to do this below… I was successfully able to get it functional afterwards and it is stable as well. I am assuming your using Windows to get to the GUI/Admin Page of IPFire, but if Linux… See both below.

Windows - Open cmd prompt and type ipconfig. Find your local address. It could be anything in the RFC1918 addressing schema. Most likely whatever you set in DHCP in IPFire for your network. Take note of the full IP address.

Linux - Open your terminal and type ifconfig and look for your used interface, and locate your ip address there, and then take note of the full IP assigned by IPFire to your local box from DHCP.

if your managing IPfire from 1 computer, use a /32 bit
I.E. 192.168.1.210/32

If your managing IPFire from all computers on your given network use a /24 bit
I.E. 192.168.1.0/24

See this screenshot for where to put that exclusion so you can get to that Cache Manager Menu.

Your entry should look like either
192.168.1.210/32 OR
192.168.1.0/24

You don’t need to add a /32 if your adding the /24 as it would automatically be included in that CIDR range.

Hiya Eric,

Well that didn’t work. In fact managed to fail wifi for awhile
until three boots later.

Apparently your suggestion appears already to have been done.
I’ve attached 3 images which may be enough to sort things out.

ifconfig
subnets
proxy - with the appearance of a block to the cache

Cheers,

Kenneth,

Have you checked the IPS logs if you have that enabled to make sure a signature definition isn’t hanging the connection you are trying to make when managing the cache manager menu? I think that was happening to me as well.

That’s an idea. What might that signature look like? Or code word for a quick search.

No signature matched Cache, Manager or cachemanager enabled.

There could be so many different signatures, you would just have to look through the logs to look for your source IP then go back to the IPS signatures to look to find the name of the signature. Unfortunately there isn’t a search or filter bar on that screen.