Backup iso 0 bytes

Hi,

When I select create iso and do a backup the iso file is 0 bytes.

I checked on the physical machine as well, just to be sure the web interface was not displaying correctly.

Even the .ipf files look small at about 1MB.

2.23 core 131

Core Update 131 is very outdated. Please upgrade to Core Update 144 and try again.

Ok, but the upgrade screen gives no option to upgrade to 144.

What files do I need to copy to preserve or re-create my current configuration?

Hi,

that’s strange.

Core Update 144 was released at April 24th; perhaps manually
clicking on “refresh list” as described at https://wiki.ipfire.org/configuration/ipfire/pakfire solves this issue.

Does DNS work on your IPFire machine?

Thanks, and best regards,
Peter Müller

Got it upgraded to 144.

And the backup is working now.

So, can I just install the iso on a new drive if my drive fails?

If I need to install from scratch, does the ipf file have, for instance the DHCP fixed leases?

Yes.

Yes.

Great!

Thanks to all for the help!

Got it upgraded to 144.

Always at your service. :wink:

And the backup is working now

Besides the obvious reason (security), this is why I asked to upgrade to the current release.

So, can I just install the iso on a new drive if my drive fails?

Yes. Please refer to the backup documentation for further information.

If I need to install from scratch, does the ipf file have, for instance the DHCP fixed leases?

I guess so, but have not checked DHCP fixed leases in particular.

https://wiki.ipfire.org/configuration/system/backup documents the major components of the backup. If you need to drill down further, the you could do an additional backup, “without log files”, that will produce a dotIPF file, which is merely a compressed text file. That can be opened and perused.

Hey ya’ll,

I started noticing the same problem under core update 144. I can do a ipf backup file with no issues, but the ISO wouldn’t spin up and remained at 0 bytes in the GUI. I wondered if the file even existed so I dropped to cli and noticed this. All .ipf files and no ISO located there in the backups directory at /var/ipfire/backup/

Upgrade to Core 145 was completed in Mid May, and I tried several times afterwards to dump an ISO backup. Every time, the GUI reflects 0 bytes and it never arrives in the backup directory. I have not modded any user/group permissions on the directory or files as an FYI. What you see is what you get above in the screenshot. Any ideas on this, or has anyone else see this reflected in their systems as well?

I just made an iso, it takes time, refresh your browser and it will appear.

you can find it in /var/tmp/backupiso/ (11th June 2020, 638pm localtime)
-rw-r–r-- 1 root root 298844160 Jun 11 18:39 ipfire-2.25.x86_64-full-core144-2020-06-11-18:38.iso

1 Like

Refreshing doesn’t mean days… I have done this several times days between and monitored it lol

Does the setup have enough disk space?

400 GB Free Space.

Eric, I just ran a backup, the iso was created in about a minute.

Oh. Crap. :frowning: Worth the shot for verifying, even if it was a quite obvious question.

Yea, ya know… i decided to run the firewall on a Dell Desktop computer with multi processor and hyperthreaded with big dang hard drive and plenty of RAM. LoL

Your at core update 144 where I was… I then upgraded to 145, tested again with the same results.

@mustangint1

you updated to 145, went to backup, selected iso, clicked, waited a min.
Do you see the iso file in /var/tmp/backupiso/ dir with today’s date?

Today, Yesterday, the day before… etc… At no time since updating to core update 144 or now at 145 did it work. Before Core update 144, it worked fine… Weird Huh? As intel, I didn’t scrap and rebuild IPFire at the bump to 144 or 145. I simply upgraded it from the GUI using pakfire.

Just now again, I tried it at 12:23 AM EST

Before Screenshot

After Screenshot

12:25 AM EST - Notice that it shows 0.00 MB…

I gave it a few minutes, because when it did work, it did take 4-5 Minutes to back the instance up to an ISO…

12:30 AM EST - I ran an ls -lach to see that mysterious ISO appear, and nadda! No sign of it. You can see for yourself, there are .ipfs that I have recently backed up with logs, but not a single .iso, like it used to perform. I imagine since the .ipf files are grouped and owned by root, that the ISO would be as well. Didn’t pay that close of attention to it before, but I would have thought it would spawn, since it was launched (requested) in the GUI.

At a loss for words yet? LOL

Thx…