Automatic Blacklist-Update doesn't work

I ran into that issue with only one machine after an core update I can’t remeber anymore and watch that issue for a pretty long time now, but it won’t fix with new core updates.

The system is configured to update the back list weekly, but it doesn’t. Also manually trigger to update won’t show up any result. I don’t have any log entries in URL Filter and System -> URL Filter at all.

I dont use any Custom source URL for shalla. Works ootb for me. I dont use automatic but iam sure this works also :slight_smile:

Logs --> System Logs --> URLFilter Blacklist

07:39:01 installpackage[urlfilter]: URL filter blacklist - Update from Shalla Secure Services completed

Hi all,
here also no problem with the URL-Filter, in my case also weekly, updates.

$ grep url /var/log/messages
Dec 21 02:50:41 ipfire installpackage[urlfilter]: URL filter blacklist - Update from Shalla Secure Services completed

and manually triggered -->

$ tailf /var/log/messages | grep url
Dec 23 07:57:38 ipfire installpackage[urlfilter]: URL filter blacklist - Update from Shalla Secure Services completed

What categories do you use ? Here the adv category logs a lot.

Best,

Erik

That’s what I was used to get but now there is all empty and it looks like nothing happens.

Hm however I can’t even login right now cause I forgot the pass and don’t have the note with it with me…

Not sure if i understood this part. So you also mean it also dont filter anything besides no log about any update? If yes and because the 138 days in the screenshot, is this a old core version? there was in the past a problem with URLFilter… i forgot what version…

Edit. thought a second again about…the problem what i meant was “only” resetting the settings… so better forget my last words :wink:

1 Like

Even if I upload a new blacklist file the update date doesn’t change. And it looks like the filter doesn’t work at all anymore -> just tested some common porn sites with no filtering, but the checkbox is set.

Is there a way to reinstall or reset the url filter?
I tried already the settings restore of an working installation with no success.

AFAIK this only works for automatic (tried on my own). I can see under Logs --> System Logs --> URLFilter Blacklist

URL filter blacklist - Blacklist update from local source completed

but the update date doesn’t change…

Iam not a big fan of fiddle arround with the settings/files if we talk about things that do not work anymore whats default shipped via IPF install. I suggest to consider, because your other suspicious problems you wrote in another thread, to do a clean install and use a backup. Sounds for me fast, easy and cleanest way…

Hi,

first thing that came to my view:

Your request for [**http://shallalist.de/Downloads/shallalist.tar.gz**](http://shallalist.de/Downloads/shallalist.tar.gz) could not be fulfilled, because the domain name **shallalist.de** could not be resolved.

Just leave that field empty. It is handled by IPFire.

A manual update - using the correct download link - should work though, but translating the databases can take a loong time depending on your machine. Try and wait.

HTH,
Matthias

i already suggest this :slight_smile:

yes but

Then look for /var/ipfire/urlfilter/blacklists/.autoupdate.last

This is the semaphore file. Check rights: nobody:nobody / 0644

Lucky me I just remembered the root passwd.

I don’t have that file at all.

Btw. I got rid of the custom link but still no success.

Thats not true :wink: Do you see the info 1 versteckt? You have do enable in winscp Listenfenster --> show hidden files

Yep you’re right.

The owner seems to be wrong.

Change root:root to nobody:nobody and you should be done…

I did that already and restarted ipfire, but nothing happens. I triggered “update now” but it’s not downloading anything and I don’t get any log entries.

Also the filter still does not filter any porn sites.

What does running

/var/ipfire/urlfilter/bin/autoupdate.pl http://www.shallalist.de/Downloads/shallalist.tar.gz

on console tell you?

-bash: /var/ipfire/urlfilter/bin/autoupdate.pl: Permission denied

Rights should be:

root@ipfire: / # ls /var/ipfire/urlfilter/bin/autoupdate.pl -ls
8 -rwxr-xr-x 1 nobody nobody 5369 Jul 14 16:59 /var/ipfire/urlfilter/bin/autoupdate.pl

=> Something messed with the file rights…

I don’t know how and why. May you pls also check the other files? Fixed the known and at least it’s downloading an update now.

The filter is also working again.