Asus AX-56 (RTL8832AU) installation

I am trying to install a driver for this USB network card, I found one here:

I have some trouble getting the repo onto the ipfire, I’m fairly new to Linux.

Let me know if you know how exactly one clones a Github repo on ipifire. Thank you.

First welcome to community!

What did you try to install the driver?
Drivers should be compiled with the kernel libs, so to add a new driver you must build IPFire your own. Or hope that one of the core devs intergrates it into the distribution.

Hmm, not sure about the compilation, first I tried to clone the repo onto the ipfire box, but none of the well known package managers (yum, zypper, apt) are present, and pakfire doesn’t show an option to clone from github.

Maybe that’s the point of a hardened distro.

The documentation of the driver says “The installation is done via make and then sudo make install.”, which I tried to follow but “make” is not present on the ipfire, and I can’t install “make” because I don’t know how to pull repos with pakfire :slight_smile: sort of a vicious circle :slight_smile:

You don’t need a package manager to download a source tar ball.
But you need the development tools ( make, compilers, … ) to build and install the driver.
These tools aren’t included in the IPFire system, for good reasons.
To build new packages for IPFire you need a development environment ( as for all operating systems ).

OK, I think I will be able to do it. But how do I get the dev tools onto ipfire in the first place?

The process is described in - Development,
especially in article - IPFire 2.x - Build Howto

1 Like