Assign MAC Address On Red (Spoofing) Not possible?

I’ve changed my ISP. I’m using an APU6, so I can assign red on the SFP port. And bypass the ISP supplied home central.
I need to spoof the Mac. This isn’t possible, or don’t work with IPFire.

(Or isn’t explained how to)

In addition I need to add Vlan 102.

I tried to do here. Only place I could find to add Vlan
Also if I like to add Vlan (101) for IPTV, this isn’t possible at all.

So how to do, or doesn’t IPFire support these features ?
I had to install openWRT, in order to make this work.
So in worst case, it’s goodbye to IPFire :sob:


Just enter your new mac into the first mac address line. The other two lines can be left blank if you are not using vdsl.

In terms of iptv and multiple vlans on =red, I believe that is what people use igmpproxy for.

I have not used it myself but I have seen other posters taking about igmpproxy and iptv.

Hopefully there will be people who can provide input.


This isn’t working. I must have a way to implement wan vlan 102 as well.

IGMP snooping is used to identify broadcast packets to either drop or forward. Won’t serve my needs.

@ms Can you help me here? Is there a way to do this ?

it is not clear to me what is exactly the problem you are facing. You asked how to change the MAC address, the solution proposed does not work? Concerning the Vlan, I cannot access the wiki now, but I remember that there is a setting like that possible in the red interface setting of a DSL provider where you set the PPP protocol.

1 Like

No, cause ISP also send over WAN / VLAN 102 normal traffic and 101 multicasting IPTV.

So I need both. Mac spoofing isn’t sufficient.

I think there is a way. When the wiki comes back online, if I find the link i will post it here.

Wiki is back up. :+1:

yes. Unfortunately the dial-up page is not very clear in the VLAN issue when using a VDSL setup for IPTV and regular traffic. The documentation there should really be improved, and unfortunately I do not have a VDSL setting at the moment to learn it myself and change the page accordingly.

Reading old threads in the community forum, like this one, it seems to me that this is how the configuration of a VDSL with IPTV and regular traffic should work:

  1. Set the correct MAC address expected by the provider

  2. Select in the dialup section, the VDSL drop down menu and write in IPTV/VLAN section the number of the VLAN dedicated to IPTV (101 according to OP previous post);

  3. In the zone configuration for the red zone, select on the correct ehternet interface attributed to the RED zone and set it to VLAN (instead of native) and put the VLAN number for the traffic other than IPTV, which should be 102 according to OP previous post

  4. Install IGMP proxy and follow the tutorial for its configuration.

For point 3, as shown by the tutorial, OP needs to configure:

  1. /etc/igmpproxy.conf; in the phyint stanza, he has to indicate the name of the IPTV vlan multicast device (I think it should be red0.101) and the correct IP range for the source of the broadcast traffic;

  2. in etc/sysconfig/firewall.local he should write the rules for IPTVINPUT and IPTVFORWARD queues for IPTABLE;

  3. use /etc/sysconfig/firewall.local to start igmpproxy at the start up of the machine.

As I said, I can be very wrong as I do not have a setup to experiment on and I barely understand the basics of these kind of systems.

Unfortunately I think few people here besides @arne_f could give some more info or correction, in case I got it wrong. I just hope that OP figures it out. If yes, I hope also that he can come back here and help improve the documentation by writing a tutorial that collects all the parts dispersed in the wiki and the forum in one place.


@ms or someone with correct knowledge ought to answer this. Yes @arne_f if he can help.

I think the best I can hope for is a script in short term.

I had to go openWRT to solve this. So I really hope some support is available.

I can even pay for the support if it involves testing a script.

So it’s working now. Sone + Mac. Strange it didn’t work first time. I suspect the reason may be that I in addition loaded an backup file.

I will also report in HW section that IPFire recommended HW isn’t able to achieve full speed when using SFP.