ARM Flash image - Boot failed while starting kernel

Hello everybody,

I’m replacing my old pfsense by IPFire.
I selected a green hardware (banana-pi R1) from the hardware page.
I downloaded the arm flash image from - IPFire 2.25 - Core Update 153
I followed the installation guide (plus the dedicated instructions on banana-pi R1 page).

However when booting, after displaying ‘starting Kernel …’ the screen becomes black and does not display anything more.

I copied a Arch Linux image instead to validate the hardware and could boot until login prompt.
I copied the image many ways (xzcat, dd on Linux, even Rufus on windows) and it didn’t solve the problem.
Finally I copied onto a different sd-card and I’m still getting the same issue.

I’m a little bit stuck now and so ask for some help here.

Thanks in advance for your help


Are you using HDMI monitor plus USB keyboard ?

If so, then you probably need 2A power supply to Banana Pi R1

Have you configured the output? Our images are set to serial console at default. If you want to use HDMI you have to change this in eENV.txt.

I checked my power suppply and it is 5V 3A.
Anyway as it was a possibility it was failing I retried with another one 5V 2.1 A and It failed to boot with the same output.

I changed uEnv.txt SERIAL_CONSOLE to OFF.
I tried to boot using serial link too (Serial USB) but couldn’t get any display (neither with minicom nor putty).

I don’t know the way to attach an image here, however the output just before ‘Loading kernel’ displays:
Cannot setup simplefb: node not found

I understood some issue with the framebuffer but don’t know if it is an issue or not at that stage.

Have you checked the md5sum of the downloaded image ? I don’t know how to get that from IPFire site, but the mirrors have it.

I didn’t take time to tell this until now, thanks a lot for your help on this issue :slight_smile:

I sha256sum the file I downloaded. Sums were matching.

I will install a Ubuntu image since the try I did with Arch Linux was only partial.
Arch is booting full text however IPFire is displaying graphical screens (I mean not pure text screens).
So using a Ubuntu image should confirm if the graphical chip is working fine.

I could install a debian-Mate image and run it properly. So no issue neither with graphic chip as I suspected nor with the hardware.
For the next step I will try the experimental arch version of ipfire and will let you know the result…

Unfortunately the aarch version only supply boot for rpi3 (not for bananapi). I couldn’t install it.
I installed instead the last build of armv5tel (build 154) with the same issue than with previous builds (Loading kernel then black screen).

I still not give up :slight_smile:
I will try to disable the automatic start of the configuration program in order to determine if the boot is failing or the configuration program display is failing.
Does someone can help me with this ?
I plan to alter the image by looking for a system V like or a systemd like and disable the start of the configuration program.
Tell me if my plan is wrong :slight_smile:

openSUSE does provide an image for bananapi. It is some years since I used it, but is still regularly updated. It does support HDMI, in text mode only, which suffices for proving capability for installing IPFire. It will be using a 5.3 kernel, which should not matter for hardware testing.
openSUSE bananapi JEOS
Installation instructions at:
installation bananapi

Or try a usb-to-serial adapter with pin connectors and use the console.

I have retested the boot on Lamobo R1 with hdmi output with core154 and it works as described in the wiki.

1 Like

I also tested the boot with core154 today on my Lamobo R1 with HDMI output by performing a fresh installation according to the instructions in the wiki and I can agree: It works fine (as described in the wiki).
Regards, A.

1 Like

Hello all

I’m back after working a while on other projects.

@df-h I booted in console mode (time to acquire the right cable). I’m still facing the same issue:
starting kernel … is displayed and nothing more.

Since everybody here (but me) is able to boot properly a Banana-pi-r1, I should consider I’m failing in preparing the sd card.
So I detail what I’m doing:

  • downloaded image: ipfire-2.25.2gb-ext4.armv5tel-full-core154.img.xz
  • Compared image sum:
    sha256sum ipfire-2.25.2gb-ext4.armv5tel-full-core154.img.xz

badcc0fbc0b0e08a3ad81d5d907bb41bf1946aeedf444be9e44a350865dd3ed5 ipfire-2.25.2gb-ext4.armv5tel-full-core154.img.xz

SHA256: badcc0fbc0b0e08a3ad81d5d907bb41bf1946aeedf444be9e44a350865dd3ed5

  • Installed the sd card (mode console):
    xzcat ipfire-2.25.2gb-ext4.armv5tel-full-core154.img.xz > /dev/sdd

  • write the boot sector:
    dd if=u-boot-sunxi-with-spl.bin of=/dev/sdd bs=1K seek=8

and that’s it :smile:

I hope I didn’t miss something

finally I missed something…

I forgot to adjust DTBSUNXI parameter to ‘sun7i-a20-lamobo-r1.dtb’ into uEnv.txt.
This value is specific to Banana-pi cards.

Now kernel is booting properly.
Thanks for your help.