ARM: access config utility in serial console?

Hi all,

I flashed the ARM version on my NanoPi R1 and later corrupted the bootloader. So I’m booting off SD but I don’t know what the command to access the config utility on the USB serial console?

Thanks in advance

Found it all the way on the bottom of the page… setup - Step 5: Network Setup

It’s not clear whether or not you later installed IPF to eMMC, via the “wget” procedure towards the bottom of:
install to eMMC

If so, then be aware that the bootloader in /usr/share/u-boot/nanopi-r1/u-boot-sunxi-with-spl.bin, is suitable only for the eMMC. If you corrupt the bootloader on uSD card then the only solution is to reflash the card.

I keep a specially configured uSD, which contains only the bootloader for eMMC. That is effectively a recovery mechanism.

If you experience repetitive boot failures after IPF updates, then I found that a better solution is to enable the boot sections on eMMC, as in the last procedure on the above page.

Hello RP,
I did get it successfully installed to the eMMC but I was screwing around with Open-WRT on SD and messed things up trying to boot to re-flash it to OEM so I can make a tutorial vid. But apparently my network settings are not working, so I reconfigured them but still can’t get DHCP to my Win7.

Setting IP to dhcp
Starting dhcpcd on the red0 interface… FAIL

Setting IP to static:
Waiting for carrier on red0… FAIL

Have you got the cabling correct ? nanopi uses Gb interface for WAN and 10/100 for LAN. It might seem illogical, but appears to work best with many modems, which don’t set 10/100 well. Network switches, OTOH, seem to cope well with 10/100 connections.

Setting red0 to STATIC should work fastest, but does require that the address set is within the valid address range for whatever would otherwise be providing a DHCP address to red0.

DHCP to your Win 7 is a totally different setting. It must be configured ENABLED at the very last step of text-mode installation in any version of IPFire. If you did not do that then the only reliable fix is complete re-installation

Son Of a :pouting_cat:… It’s working after I switched the the 1Gb to WAN and 100Mb to LAN. I’m can’t believe it was just that. :tired_face:. I pulled off the case after I had issues connecting and decided to use the internal serial header. I did see a stick on the NIC that said Gb but didn’t relate it to the WAN until u mentioned it. Thank you so much RP! :kissing_heart:

-So for this to work I have to use the 100Mb to LAN? Man I can’ t use this thing.

The 100 Mb LAN is only for interchange with the Internet. If you have a Gb ethernet switch, your workstations can interchange at Gb speeds - mine do.

If you really need > 100 Mb to Internet then a USB2-ethernet adapter might get you to 240 Mb

If you must have Gb Internet, then one community member is working on the nanopi R4, which has dual Gb ethernet.

BTW, the internal serial connection is not usable with the way IPF is configured.

1 Like

One additional question. Did not properly shutdown, it corrupted the eMMC? Last I see…

dracut Warning: filesystem)

Generating “/run/initramfs/rdsosreport.txt”
You might want to save “/run/initramfs/rdsosreport.txt” to a USB stick or /boot
after mounting them and attach it to a bug report.

To get more debug information in the report,
reboot with “rd.debug” added to the kernel command line.

Dropping to debug shell.


I can’t answer your question. I usually do upgrades via Pakfire WUI and don’t see those messages. It was routinely corrupting u-boot on the eMMC, which is why I enabled the boot sections on eMMC, but since then there have not been kernel upgrades.

1 Like

Thanks, really appreciate all the help. :sunglasses:
I also just figured out I have been complication myself setting up the network, wasn’t able to run the wget download command. Figured it out after I wasn’t getting to but able to get to due to using cloudflare public DNS ( … Ugh! :dizzy_face:

Is there an easy way to set the primary and secondary DNS? I ran the setup command but don’t see options to reset the DNS, unless I image the SD card again?

Also I believed I figured out the NICs

DNS is now set via WUI. See guide at: DNS setting

It defaults to using ISP’s DNS, which should work, but probably not securely. Other discussion threads have discussed how to optimise this. Lightning Wire Labs DNS server works consistently well for me.

You do have the optimum assigment of NIC

1 Like

Thanks for all the help, I’m up, running and have learnt alot! :+1::cowboy_hat_face: