APU4D4 IPFire-ready

I recently purchased a IPFire-ready APU4D4 from vario-store. This device didn’t work out of the box as expected.
I contacted varia-store and they will apparently give me a return ticket.
Anyway, I want to give it a try to solve the problem before sending the device back to varia-store.
After reception, I connected a laptop (MacBook) to the second eth-port and powered up the device, and got IP-address 0.
I connected the first eth-port (the one closest to DB9) to the ISP-router, but the ISP-router didn’t see anything and of course didn’t give a Ip-address.
So, I decided to connect to the serial port with a USB to serial connector (115200 8N1) that I had laying around (forgot to order the apropriate convertor-cable from vario-store) and rebooted the device again.
I didn’t see anything in the serial console (Serial.app as well as iTerm), but was able to connect to
The day after the APU didn’t boot anymore from the SD-card.
I then installed OPNSense on a USB-stick, removed the SD-card, and booted into OPNSense from the USB-stick. OPNSense worked (LAN, WAN, SSH, …).
I powered off from within OPNSense menu and rebooted with the USB-stick left in place without success and still no serial console (tested with two different, and functioning, USB two serial devices).
This morning, I gave it again a try with the IPFire-ready SD-card (what’s in a name :slight_smile: ) and a Linux computer. Now, there is life in the console, but all characters are unreadable and APU doesn’t give me a IP-address.
So, before sending the device back to vario-store, is there anybody who can give me advice to get this APU functioning ?

Do a clean install of ipfire.

1 Like

Thank you for your suggestion.
I did a clean install (img-file) according to the instructions you send me on a brand new SD-card but to no avail.
Installing OPNSense on the same SD-card is OK, but still no functioning console.

Sounds Strange. Can you sent some pictures please. Does ipfire boot up?

When booting the image for the first time, you have to have the device connected to the serial console already and hit arrow up or down in the very first moment, to get the boot menue and option to boot into serial gui. If you miss that moment, the device auto-boots into graphical installation modus and you see only garbled output. Then you have to flash the image again…

1 Like

Hello, and thank you for replying in this topic.

The serial console has always been connected before powering up.

and hit arrow up or down in the very first moment
What do you mean with “at the very first moment” ? How many time do I have after powering on ?
(with OpenWRT you clearly see the booting process in the console, and after a while there is a 3 sec. and you get a message that you can interupt the boot process by pressing a key).

A support technicien of vario-store let me know that not all USB2serial devices work on APU, and they don’t know why.
I tried two of them : https://www.adafruit.com/product/954 and https://www.velleman.eu/products/view/?id=441224


Of course I can sent some pictures, but from what ? Screen grabs of the console window, hardware pictures, both, … ?

Does it boot ?
I suppose not because nothing is functioning. But I have no clue what is happening because of the not-functioning console.


https://store.lightningwirelabs.com/products/USB-COM-ADAPTER this works on my apu which i have bought by lwl. I’m not part of it. Just good stuff which works here

1 Like

Hit one of the the arrow keys several times immediately after powering on the device, I had this behaviour (failover into graphical mode) with an Alix-Board. Once you missed it, the installation will remain in graphical mode and present always garbled output. Concerning the serial USB Adapter: I use an old PC, which still has a serial connector onboard, and a nullmodem 9 pin cable.