APU2C2 Change console to com2 (onboard header)

Hi !

I know that i can’t change this on startup to this com port… but for ipfire i want to change it to com2 because i might use Com1 for UPS

Ciao Gerd

You can change the used port in /etc/defaults/grub
After editing this file you can regenerate the grub configwith grubmkconfig

change it like this

GRUB_CMDLINE_LINUX="panic=10 console=ttyS0,115200n8"
GRUB_SERIAL_COMMAND="serial --unit=0 --speed=115200"

to this

GRUB_CMDLINE_LINUX="panic=10 console=ttyS1,115200n8"
GRUB_SERIAL_COMMAND="serial --unit=1 --speed=115200"

Ciao Gerd

1 Like

I Changed it to the settings in 2nd block but i still got not response from com2… i get ther terminal (starting linux) still on com1
ok i got it…

Ciao Gerd

Have you regenerated the grub conf file with grubmkconfig -o /boot/grub/grub.conf (im not sure about the correct name)

hi !

Yes and still on ttyS0 :frowning:

Ciao gerd