"An error occured when the backup file was restored"

My ipfire’s partition layout still uses the old version, so I want to reinstall to get the new layout. Have made a backup via GUI and choose “iso”. Running Core 161.

Installation starts and completes, then I get asked if I want to restore the backup that was found. Choose yes and get “An error occured when the backup file was restored”. No further explanation, no way to check any log files.

I could access the system and tried to restore the ipf file via GUI. Seemed to upload something but then nothing happened. No error message, no success message. Just the same screen as before. Reboot didn’t change anything. Had to use Clonezilla to restore the disk image I made before.

I could open the corresponding ipf file as an archive and test it. Found no problems.
I was able to reproduce the problem on a VirtualBox machine.

Why is this happening?
How can I debug this?

Problem is the included ipf file not being gzipped as expected. See 12737 – Failed restore from iso only states "An error occured when the backup file was restored"

Use Alt+F2 to see detailed output.

1 Like

Is it only a problem under Core 161 and fixed in 162?
Because I ran in the same situation with a 161-Restore today!

No, seems to be the same with 162!

When will it be fixed?

The patch has been merged into the Core Update 163 build so will be a part of that release.