After update to 142 no wifi

I just updated to 142, and the built-in (on-motherboard) wifi card, it’s an Intel 802.11as WiFi Module, no longer works and is not recognized. The prior build worked.

It appears that, apart from a complete reinstall (days of work), I cannot roll back. And I no longer have Wifi.

Are there any steps to resolve/fix this issue? Stuck at home during coronavirus, it’s problematic to have no wifi.

Which one? There are lots out there.

Intel WIFI built in card in AP mode? Haven’t seen this working for many years with modern cards.

This is up to you if you don’t make a backup and update.

$ lspci

05:00.0 Network controller: Intel Corporation Wireless 8260 (rev 3a)

WLAN AP based on hostapd working perfectly rock solid stable for years now.

This is an on-board chip on a brand new ASRock Motherboard (Z390M-ITX/AC), which has an Intel Dual Band Wireless AC 3168NGW [Stone Peak] chip.

It isn’t that old, it was a brand new chip in 2016.

And virtually all flavors of Linux support it.

Please Note

I tried to reinstall 142, and tried 141 also; neither picks up this chipset. However, if I go back to 139, that version does pick it up.

So somewhere something broke, or someone inadvertently deleted a driver?

Check if your corresponding firmware “iwlwifi-XXXXX.ucode” is provided in /lib/firmware.
See below.

$ ll /lib/firmware/iwlwifi-316*
-rw-r–r-- 1 root root 1384856 Jun 29 2018 /lib/firmware/iwlwifi-3168-21.ucode
-rw-r–r-- 1 root root 1028092 Jun 29 2018 /lib/firmware/iwlwifi-3168-22.ucode
-rw-r–r-- 1 root root 1032436 Jun 29 2018 /lib/firmware/iwlwifi-3168-27.ucode
-rw-r–r-- 1 root root 1036300 Dec 14 09:28 /lib/firmware/iwlwifi-3168-29.ucode

Intel® Dualband-Wireless-AC 3168
4.6+
iwlwifi-3168-ucode-22.361476.0.tgz

It still doesn’t pick it up. 139 works, 141 and later are broken for me. Unsure about 140. Not sure what next steps to try.

More info…

Detected Intel Dual Band Wireless AC 3168…
Can’t parse phy_sku in B0, empty sections
Failed to read NVM: -61

See: https://bugzilla.kernel.org/show_bug.cgi?id=206333

More: https://www.reddit.com/r/linuxquestions/comments/eyw2bx/iwlwifi_drivers_not_working_on_intel_ac_3168/

Looks like kernel 4.14.174 fixes this. Your most recent version is “kernel: update to 4.14.172”
https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/log/?h=linux-4.14.y

This is not correct it is 4.14.173 but it still affected…
We also not recommend Intel cards at all because they are not work in client mode and most of them in AP mode only at channel 1-11 because they are shipped in “World-00” mode in eeprom/flash and there is no user tool to set up the country correctly.