Adding new hostname does not refresh unbound correctly in core 151

Hi all,

This is a bug but I could be wrong. The issue is, anytime I add a new hostname on ipfire GUI under Networks > Edit Host. I loose all access to the custom host using the new hostname when I run ping for them. For instance, my internet IP is, local domain is ipfire.local and my blue network is In a normal situation before the current update (151) when I add new host (demo.ipfire.local with IP I can ping by name demo or demo.ipfire.local and I will get But with the recent update the ping returns

To resolve this, I had to manually reload the unbound (DNS server on ipfire) before I could get the current IP - /etc/init.d/unbound reload*. Does this affect anyone else?

I have Core Update 151 and I just tried creating a hostname and then pinging it with just the hostname and with the FQDN. In both situations ping came back with the correct IP. So I cannot duplicate what you are finding.

Unfortunately I cannot help you further with regard to why you are having this behaviour with your system as my skills do not cover this.

Many thanks for checking.