Access Cable Modem from IPFire


My current network setup is:
Vodafone cable -> cable modem: Fritzbox 6591 ( -> exposed host ( -> IPFire (green: -> Windows clients

There is no issue with this configuration with one exception: SIP telephony.
I’ve to configure a SIP software on a client in green, that must access the Fritzbox, since this device handles SIP phoning with Vodafone. While the Fritzbox can be accessed from green, using its IP-address, the software setup basically works.

But I encountered issues with the voice quality and certain other issues like interrupts or similar. Mostly when I initiate a call.
The programmer told me this is due to NAT problems, because the green client is not in the same IP range as the Fritzbox.

So what options do I have without changing the network setup?
Can I setup a static route to the Fritzbox that would solve this issue or will I still see those NAT problems? If yes, how would I configure this in WebIF of IPFire?

For example, set up a (new, static) IP-address from the green address range, for the Fritzbox, to reach the Fritzbox from green IP range?

Maybe a forward rule would do the job, too, instead of a route?


Could this be the source of your problem?

Thanks for posting. I shouldnhave mentioned that a another software , MicroSIP, works without any issues.

Whereas software PhonerLite is causing above explained troubles in my setup.

Since it could be a NAT problem…

Aren’t you double NAT’ed? Once with the Fritzbox and once with the IPFire??

MANY years ago I was taught double NATing was “bad” and to avoid setting things up this way. Things have changed over 15 years so I could be wrong.

You may want to try setting the Fritzbox up in bridge mode. This might help.

For me, the top two blurred out addresses are Internet IP addresses and not a NAT’ed IP address.

The Fritzbox in front of IPfire is set up to pass on all traffkc from external to IPfire without any intervention. The config on the Fritzbox says about exposed host. This should be an equivalent of bridged mode, but I may be wrong.

There is no port forwarding or similar involved. Unless I miss the obvious, I would assum there is no double NAT in place.

from what I’ve read on “The Internet” it looks like the Fritzbox 6591 cannot do bridge mode. So my comments won’t help.

Yes, that’s my limited knowledge, too :wink: only exposed host is similar to a bridged mode.