About dhcp option wpad

When dhcp option wpad is enabled, Windows 10 cannot get IP address from dhcp, use wireless network to connect IPFire. How to fix this, is this a bug of IPFire?

This may be a bug of the dhcp option wpad.
option wpad;

Generic error:
DHCP server exiting.: 3 Time(s)

Unknown Entries:
/etc/dhcp/dhcpd.conf line 18: semicolon expected.: 3 Time(s)
/etc/dhcp/dhcpd.conf line 33: semicolon expected.: 1 Time(s)
Configuration file errors encountered – exiting: 3 Time(s)
If you think you have received this message due to a bug rather: 3 Time(s)
^: 4 Time(s)
^Ioption wpad http:: 4 Time(s)

Can you look at the contents of /etc/dhcp/dhcpcd.conf?
Have you edited it? Are there line endings with CRLF?

I’ve just checked the source of dhcp.cgi.
The lines for the DHCP options in dhcpcd.conf are written correctly, with ‘;’.

I haven’t edited dhcpd.conf, wpad option is an option added in webui

There is no problem with this line.
option wpad code 252=text;

When enabling this line is problematic.
option wpad;

Is this the line in dhcpd.conf?
It should read
option wpad “”;

Also /var/ipfire/dhcp/advoptions should contain something like

on wpad  ""   off BLUE 
on wpad  "" GREEN off
on wpad  code 252=text off off

Like this. I found the problem because there are no quotes

I just checked the source and toggled the ‘enabled’ button for the option.
Both files ( /var/ipfire/dhcp/advoptions and /var/ipfire/dhcp/dhcpd.conf ) contain the quotes.
Didn’t check a new definition, yet.