3Com 3c59x driver

Hi guys, I’m running Ipfire on an old HP hardware. It worked fine for me, since a network card (3Com 3c900-COMBO) broke. I replaced it with a 3Com 3c905B 100BaseTX (that is reported here https://fireinfo.ipfire.org/drivers/3c59x to work with 3c59x driver), but I’m not able to make it work.

lspci output reports:
01:01.0 Ethernet controller: 3Com Corporation Device 0000 (rev 24)
01:08.0 Ethernet controller: Intel Corporation 82562EZ 10/100 Ethernet Controller (rev 02)

lspci -nn -vv -s 01:01.0 reports:
01:01.0 Ethernet controller [0200]: 3Com Corporation Device [10b7:0000] (rev 24)

  •    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-*
  •    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-*
  •    Latency: 32, Cache Line Size: 32 bytes*
  •    Interrupt: pin A routed to IRQ 5*
  •    Region 0: I/O ports at bc00 [size=128]*
  •    Region 1: Memory at fe5ffc00 (32-bit, non-prefetchable) [size=128]*
  •    Expansion ROM at fe5c0000 [disabled] [size=128K]*
  •    Capabilities: [dc] Power Management version 1*
  •            Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)*
  •            Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-*

so it seems the card is perfectly recognized, but the driver module isn’t loaded.

modprobe 3c59x seems to work fine, without errors, and lsmod reports
Module Size Used by
3c59x 49152 0

but the card appears to the system as if it was not installed, it doesn’t appear in ifconfig report, and the setup utility says that there aren’t interfaces not assigned (but the only one assigned is the Intel 10/100 on the Green interface). I also tried loading the module with the parameters:

modprobe 3c59x io=0xbc00 irq=5

but things don’t change.

Any suggestion?

Thanks in advance.

P.S. I forgot: I’m running Ipfire 2.25

Device id 0000 looks suspect to me and is not in the supported cards list of 3c59x.
Looks like this card or your mainboard is faulty.

1 Like

Thanks to your hint, I searched for the device ID of that NIC, and it should be 10b7:9055, not 10b7:0000 as reported by lspci. I’ll try with a different device. Thanks for your help.

Thumbs up: I changed the NIC and all went silky smooth. Thanks for your help, I was distracted by the fact that the NIC was listed by lspci and didn’t focused on device ID set to zero.