2nd USB ethernet adapter not recognized after reboot unless replugged

I agree. It should be documented.

1 Like

@jon If you create a stub for an entry explaining rc.local in the wiki, I will take my post above and restructure it, with links and everything and fill up the wiki entry. If you agree, should this cover both files (rc.local and firewall.local)?

1 Like

How about here:


firewall.local already has a wiki page:

So maybe add links and/or notes to the firewall.local page

1 Like

If the 8153 keeps getting detected as 8151, why not just blacklisting the device 8151 in udev? I think the path in IPFire should be /etc/udev/rules.d/23-usb.rules.
Here’s a small writing about how this could be done:

What about adding some support (via an additional .local file for example) for blacklisting devices? So that it won’t get overwritten by the next update?

1 Like

Don’t create your rule in 23-usb.rules but create a new rule file such as 99-disable-8151-usb.rules and add the disable info in that. Then it won’t be overwritten by a core update. You can also add that file name to your include.user file so it is backed up and available for restore if you need to do a fresh install etc.

I think that should give you what you are looking for.