2.25 core 156 testing: feedback

Thanks a lot for the updated version available, which was tested as virtual machine on microsoft hyper-v (updating a productive installation). Here’s my short feedback:
(1) When trying “status” \ “who is online” I encountered an “internal server error”
(2) I personally regret very much that the gui style “ipfire-legacy” will not be available any more
(3) “Live graphs” is a very good idea and I recognized that the chosen time-interval is marked now, BUT live graphs would be more useful with shorter time intervals, e.g. “10 min” or so for real time monitoring purposes

Hi @baruch234

I didn’t get this result when I tried it. Was wio already installed when you updated.
I installed wio in my vm testbed after upgrading to Core Update 156.

I will try again but with wio installed in a Core Update 155 vm and then upgrade.

What do you find in the error log

/var/log/httpd/error_log

It would be good to raise the problem you found in Bugzilla, together with the error_log output.

https://wiki.ipfire.org/devel/bugzilla

Your IPFire Community email address and password will get you logged in to the IPFire Bugzilla.
Include Core Update 156 Testing in the title so the devs can easily see any bugs related to the testing.

I updated the running machine with WIO already installed and configured.
After encountering the described error I reset the vm to the conserved snapshot, so actually, error_log is not available any more but I will try to reproduce the situation and report it in more detail.

I have just tried with Wii installed and running on Core Uodate 155 and the upgraded to 156 and then accessed wio on the WUI.

No issue again for me.

Will be interesting to see if it re-occurs when you redo the steps.

I redid the steps: update running vm on core155 to core156, reboot:
access the gui: works
“status” \ “who is online”, result: “Internal server error” (reproduceable)
error_log contains the following information (personal information replaced):

Unable to read file /srv/web/ipfire/html/themes/ipfire-legacy/include/colors.txt at /var/ipfire/general-functions.pl line 149.
Compilation failed in require at /srv/web/ipfire/cgi-bin/wio.cgi line 54.
[Tue Apr 20 10:13:12.334684 2021] [cgid:error] [pid 3047:tid 135351590970944] [client myclientip:54113] End of script output before headers: wio.cgi, referer: https://myipfire.mydomain.local:444/
Unable to read file /srv/web/ipfire/html/themes/ipfire-legacy/include/colors.txt at /var/ipfire/general-functions.pl line 149.
Compilation failed in require at /srv/web/ipfire/cgi-bin/wio.cgi line 54.
[Tue Apr 20 10:17:02.931606 2021] [cgid:error] [pid 3047:tid 135351960053312] [client myclientip:54195] End of script output before headers: wio.cgi, referer: https://myipfire.mydomain.local:444/

Hi @baruch234

I think I know what the problem is.
The themes are all removed for Core Update 156, so there is only the default ipfire version left.

Your previous version had the ipfire-legacy theme set, I think, and you did the upgrade with that in place. Your error message mentions ipfire-legacy.

I believe that is leaving a setting in place for wio that is not getting corrected during the upgrade.
I did a test of that approach with my vm and I got the same Internal Server error message as you did.

I think you should raise this as a bug in the IPFire Bugzilla.

To solve the problem for yourself what you can do is revert to your snapshot, change the theme to ipfire and save and then do the upgrade. That combination worked with no problems for me. It is a workaround not a solution but it allows you to do your testing.

Hello,

thank you for your answer - I had the same idea this morning and had a look at the IPFire Bugzilla too, but it seemed to be confusing (…) - sorry.

I have had the same issue with my vm, so I will raise it as a bug then and cite this forum thread.

thanks, I will have a look at it afterwards.

Bug has been raised

https://bugzilla.ipfire.org/show_bug.cgi?id=12612

wio is completely broken in my case - since a long time.
This plugin is not working. It doesnt matter what i do - it is showing “updating” and nothing happens anymore.
The dev of this plugin doesnt seem to care about…

I’m seeing simialr situation after upgrade to test ver 156. However, I’m not using a VM and I can’t even get to the web GUI without getting the server error.

My log entries in the error log are slight diffterent though.
“[Thu Apr 22 14:56:47.133346 2021] [core:notice] [pid 4789:tid 135707341001728] AH00094: Command line: ‘/usr/sbin/httpd’
/var/ipfire/header.pl did not return a true value at /srv/web/ipfire/cgi-bin/index.cgi line 32.
[Thu Apr 22 14:57:58.687299 2021] [cgid:error] [pid 4791:tid 135707302057536] [client 192.168.xx.xxx:51190] End of script output before headers: index.cgi
/var/ipfire/header.pl did not return a true value at /srv/web/ipfire/cgi-bin/index.cgi line 32.”

(Note IP replaced with .xx.xxx)

Should I go and add to the bug report already created, and add my error_log to it ?

Also, is there a CL cmd that I can use to revert back to the 155 version ?
Stupid me :confused: should have imaged the drive before doing an upgrade to a test version.

Thanks

Your error message is something different and not related to the themes.
So I think you should raise a new bug for that.

Your IPFire email address and password will log you in to the IPFire Bugzilla

Re reverting to 155. There are some threads in the forum where people have changed certain files to enable them to go pretend to be two updates earlier (154) and then upgrade to 155 but not everything gets returned back.
The simplest and most certain is to re-instsll 155 and restore from your backup.

Ok thanks.
I’ll create the bug report, and do the new download scenario.

Bug 12613 submitted

These kind of error messages (" ...xxx.pl did not return a true value at ... ") appear, because xxx.pl is used (with require xxx.pl;) by some other perl file. All such require'd files should return true value. Usually those files have just “1;” on last line.
I had to make this kind of fix on my test IPFire while I did upgrade Core 155 → Core 156. I had made some private changes on that machine and I thought that I had broken it myself. Apparently not.

1 Like

Just noticed today Hostapd UI also returned a server error message with the following httpd logs

[Sun Apr 25 10:10:33.172993 2021] [cgid:error] [pid 6557:tid 3013604272] [client 192.168.1.97:65516] End of script output before headers: wlanap.cgi, referer: https://192.168.1.1:444/
Undefined subroutine &Network::get_intf_by_address called at /srv/web/ipfire/cgi-bin/wlanap.cgi line 85.
[Sun Apr 25 10:12:53.485539 2021] [cgid:error] [pid 6557:tid 2914997168] [client 192.168.1.97:49210] End of script output before headers: wlanap.cgi, referer: https://192.168.1.1:444/
command failed: No such device (-19)
command failed: No such file or directory (-2)

To recover from the error

  1. Uninstalled & Reinstalled hostapd package
  2. The WLanAP page loaded reporting “interface error, do you want to remove interface”
  3. Respond with “Yes”
  4. Select as new interface “blue0”
  5. Everything is now back to normal

Not sure if this is a separate issue or related to the UI refactoring work as part of 156

Running
IPFire 2.25 (armv5tel) - Core Update 156 Development Build: master/cea9d7b3

After upgrade to 156 every graph is shown very small.


Can I change it.?
By the way, no problems with the installed version of wio.

Hi @hico.

Maybe this help you:

Theme for ipfire - IPFire Community

Tell us.

Regards.

1 Like