2.25 Core 143 testing

works well so far. Thanks.

1 Like

Since the core update 142 stable to 143 testing (via Pakfire > testing repository), I can no longer connect to SSH port 222 (Note: The SSH service is well started !)

Edit1 : Login, password and port are saved in WinSCP (SFTP - 222) so no possibility of being wrong…

Edit2 : It seems that the update was not done well, the line highlighted in yellow was missing

IPfire update
To fix it :

  • Root login with the command line
  • Change repository branch from Testing to Stable (IPFire > Pakfire)
  • Editing the file /opt/pakfire/db/core/mine and change 143 to 141
  • Click on the “Refresh list” button then update to 142 then reboot
  • Change repository branch from Stable to Testing (IPFire> Pakfire)
  • Click on the “Refresh list” button then update to 143 testing then reboot

SSH Ok ! Problem solved !

No problem here, with IPFire on ARM SBC. I do use the default port 222.

" Bluetooth

The Bluetooth add-ons has been dropped because there is no application for it in IPFire. Wireless modems could be used before, but since this is not widely used, we have decided to drop the add-on."

Doesn’t that conflict with samba? I use the samba addon and the bluetooth addon was installed with it (dependency).

Bluetooth was pulled in for CUPS. Samba is linked against CUPS.

CUPS used the bluetooth stack to talk to bluetooth printers. I don’t think those are widely used.

I don’t need/use bluetooth with ipfire. As long as samba still works and not complains about missing dependencies I’m fine :smiley:.

I had a DNS failure, that might have been self-inflicted.

I had a spare SSD for my i586 IPFire and wanted to use that rather than the production SSD, to test core 143. It was installed with core 141, which I upgraded to 143. Then I realised that it was a fresh installation, to which I had not restored the backup for core 141. After I did that, DNS was unworkable:

not resolving
constantly reporting “broken”, even with a Lightning Wire Labs server
neither UDP or TLS worked
unbound not starting after reboot
any change via Web Interface stopped unbound, without restarting it

I resorted to restoring the backup from after upgrade to core 142. That had only initial settings but got unbound working reliably, with the default of “ISP assigned servers”. Then changed settings to “recursor mode” & TLS - which continues working.

I recall that, about core 141, we were advising people to do fresh installs, to get rid of partitioning schemes that were no longer viable and stale libaries. It appears that restoring older backups can cause problems.

Good afternoon.

I just updated my IPFire to test version 143 and for now it is totally satisfactory. I have tested both the UDP and TLS module and they both seem to work correctly.

I have even tried SafeSearch and it seems to work correctly.

My total thanks to the entire IPFire team :+1:.


Started testing: firewall groups still don’t work: Iptables "host/network 'none' not found"

I’m confused, what is the correct link for the testing version?

For fresh install use:

For update switch the tree from stable to testing in the WebUI -> IPFire -> Pakfire

is now running stable for 8 days without any problems.

There is a problem (maybe also with previous versions). I changesd the RED interface from WLAN to LAN. The network card got active and the link established, but the status kept beeing “Establish connection” and the firewall stayed offline and didn’t request a IP from the DHCP server. I did a restart and it worked without any changes so there is something missing that needs to be restartet after changing the device :roll_eyes:.

Edit: just did the same but the other way around with the same result - firewall stays offline… so I’m safe! :smiling_imp:

This has long been an issue with IPFire.

I can change GREEN interface readily, but not RED. A reboot might also be needed when the WAN link sporadically drops.

Wow Trump says that this is really really bad. However this is not the case with an fixed IP configuration (usually I do so). At my parents place I had an test installation with WWAN and the opportunity to switch back to ADSL, so 2 different modems and I set up ipfire RED with DHCP in case they switch back, but I got calls that the internet failed many times. I was there, the internet worked so ipfire, but it wasn’t online. Now I know why :grimacing:.

Anybody got time for that?