Web page on ipFire not visible externally

Hi All,

Everything his worked very nicely with my new install of ipFire.

One nagging problem:

I have a web page run by nginx on ipFire.

I can view the web page on my local network, but I cannot view it from the external wan.

Configuring firewalls and rules is new to me. What do I need to do to see this web page externally?

Thanks

Read thru this:

And then read thru this:

Sorry for the homework but this will help you get started.

If you have any questions, please let us know!

2 Likes

So I have nginx with my web page running on my ipFire server, but I get the following strange behavior:

  1. If I try to access the web page from the external WAN I get a connection reset. Both using the URL and my IP.
  2. If I use the local IP of the ipFire server I get my web page. So nginx is running.
  3. If I use my URL locally I get the logon page of my cablemodem. Huh?

Not sure if this is an ipFire problem, a cablemodem problem, firewall problem, or something else.

Thanks for any assistance.

1= As Jon pointed out you need a port forward.
2= your modem is most likely using port 80 so it is most likely block by modem.
( ISP wants money for that kind of thing.)
would not be surprised if port 443 is blocked too.
Would try none standard port for nginx. and port forward
You have a lot of possible problems. nginx config?
Good luck

Thanks, Shaun.

I have Comcast commercial service. The cable modem has an “advanced” and “basic” bridge mode. Since I don’t what these are, I have shut down everything on the modem, including NAT and I have DMZ’ed everything to my server. All ports should be open to my ipFire server. The cable modems are cryptic on their settings with little information on what the consequences are. It did work OK on my previous server.

I have tried all kinds of port forwarding rules on ipFire, without success.

I’m missing something here…

I have Comcast home and have the cable modem set to bridge mode. But there is no “advanced” and “basic” modes. NAT turns off in bridge mode which is good!

This wiki article should open the IPFire port 80 to a GREEN network device.

I’ve used this Wiki article to open a different port to GREEN and it worked as expected for me. I don’t know how a port forward to DMZ/ORANGE is different.

EDIT: This might help also:

1 Like

huge thanks for the link. i find it all very helpful

2 Likes